Help: Texture disappears in rendered mode after saving file

Hi everybody,

I have been a long time Rhino user, and this forum has helped me more than once as a spectator. So thank you all for that. But now I have no luck in finding a similar problem on the forum, hence my first post here (yay).

So I am hoping that one of you guys can help me out.

The problem description is as follows:

  • When I create a material for a piece of geometry and add an image ( for example .jpg) as a diffuse color texture it shows fine, until I save the file, close it and open it again. Then the texture doesn’t show in rendered mode. Instead it often shows some sort of standard studio environment image. When I replace the texture with a completely different image file, or change the file name, it shows fine again. Until I save the file, close it and open it again.

As I said: sometimes instead of the diffuse texture image, Rhino shows some sort of studio environment image as diffuse image. Like this:

And sometimes Rhino swaps out diffuse texture images between different materials, like this:

This is driving me nuts. Hopefully, somebody here has a solution.

  • I am having this problem since Rhino 7.
  • It does not always happen.
  • My RHINO system info can be found at the bottom of my post.
  • My Video hardware and driver information is as follows:

Radeon RX 590 Series
OpenGL version: 4.6.13596 Compatibility Profile Context 27.20.1034.6
Render version: 4.6
Shading Language: 4.60
Driver Date: 8-21-2020
Driver Version: 27.20.1034.6

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Stencil depth: 8bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)
Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Radeon RX 590 Series (AMD) Memory: 8GB, Driver date: 8-21-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context 27.20.1034.6
> Accelerated graphics device with 8 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 8-21-2020
Driver Version: 27.20.1034.6
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)\1.0.7284.18297\Iris.WinR6.rhp “Iris”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.7.29.584\SectionTools.rhp “SectionTools”

Hello - I think the first thing to try is to disable the above plug-ins in Options > Plug-ins page and then close Rhino and start it again - is there any difference in behavior?


Hi Pascal,

Thanks for your suggestion, but unfortunately that doesn’t work.
At first I thought it did the trick, but once I opened the file again, the mismatched textures popped up again.

Any other ideas?

Hello - can you post or, if confidential, send to, along with a link back to this topic, a small (if possible) file that shows the problem?


Hi Pascal,

Certainly. I’ve added a part of a file that shows the problem.

I have just noticed something weird as well. The behavior is pretty random. And I tried to recreate the steps that lead to the problem and summarize what happens with steps below .

  1. When I opened the file directly by double clicking the file it shows problematic textures, like this:

  1. But if I open the file by first opening Rhino and then selecting it from the recent files in the Rhino splash screen, it shows the textures without any problem. Like this:

and it opens like this:

  1. Now when I subsequently save the file I have just opened via the splash screen and then open it again by directly clicking the file’s icon, shows the textures without any problems again. Like this:

  1. But when I add a piece of geometry (a simple mesh cube), and assign a new custom texture with a .jpg as diffuse, save it, close it and open it again, it doesn’t show any textures anymore. like this:

  1. Open it via the splash screen again and it looks fine, like this:

  1. Now when I save it and open it by directly clicking the file icon, The textures are gone again. Which was not the case when executing step 3).

  2. Another way I tried to open the file is by first opening Rhino and then open the file via File > open. It seems to open normally that way, as it does via the splash screen. But when I repeat the above steps, I get the same results.

Hopefully, the above information and the uploaded file is sufficient information to understand and troubleshoot the problem. But please let me know if there is anything else you need.

I really appreciate your help. Thanks in advance.

ProblematicTextureFile.3dm (13.8 MB)

Hello- Thanks for the file and details - I confess I am mystified as to why you are seeing what you are - so far at least it all just works, here. But, I’ll ask a bigger brain - @brian - do you have an idea why opening a file from the splash screen would behave so differently, as outlined in the post above, from opening from Explorer?


Wow, I don’t really have any idea. Texture resolution is something I think @andy’s team would need to look into.