Help, Rhino turntable animation cant do larger than viewport

is the turntable animation tied to viewport max size, and i cant change to larger like in single still renders?
Trying to do a 1440x2560 turntable animation render. but my screen view port max is 1064…
I set the render for th desired render size,

but when i do "record animation. it still does the v

Also, when “recording animation” what is this setting? is it the passes for the render output file, or just what i see on the preview. like, would a higher number make the exported picture animation better quality ?

Hi Mikele -

It looks like you need to set the Capture method to RenderFull for the resolution settings in the Render panel to take effect.


That should be the number of passes for the final image but I don’t know what takes precedence. Perhaps @nathanletwory knows…

NumberOfPassesForRealtimeDisplay is for capturing Raytraced view, or any third-party viewport integration that uses passes system.

OH, I was doing “raytrace”

I see renderfull works and captures the setting size i set.
but wierd… i had the NumberOfPassesForRealtimeDisplay set to 500
but it shows 50, yet now it takes 2 minutes to render a white cube with no materail… (takes 15sec if i do render button (2min per frame if ‘record animation’)


Full render wuill use the quality setting, which in your last screenshot is Draft quality, equaling 50 samples. The realtime display samples setting is for exactly that, Raytraced or any other viewport integration that uses the system.

If you want to specify exact amount of samples for Rhino Render you need to scroll a bit down to the advanced render settings, check the override render quality box and set the sample count you want.

Thank you, so clear on that info now.

maybe add to the documentation.
its missing those points on the RecordAnimation command info

You’re looking at Rhino 5 documentation, the passes setting was added in Rhino 7, since the command didn’t work with realtime display integrations at all.

That said, explanation for the new setting is still missing. @KelvinC can you add that to the docs?

1 Like

I can’t find any Youtrack issue that added the NumberOfPassesForRealtimeDisplay option. It might be added in RH-57903 that is still in the open state. The option is now added to the topic.

1 Like