Help needed USB thumb drive not recognized

unhandled

#1

Hey gang…

Got a problem with one of my USB thumb drives.

On both mac and windows the drive is not
recognized at all.
Even as a device in general. It’s like I’m sticking
in a stick of gum in the USB port.

Is from sandisk. And what I did, as smart as
I am, saw hidden files, some including exe files, inf files, I think, and deleted them all except for the actual data stored.

The data’s not so critical as it’s some older backup, but would like to get the drive back to use…

Thought the files were like virus and deleted them…


(John Brock) #2

Try Disk Utility in MacOS or Disk Manager in Windows.
The data is probably toast.


#3

Doh… Tried the disk manager, but nothing shown for the usb drive…
Will try with mac later…


#4

Tried with the mac Disk Utility… but nothing…
I guess the USB disk itself is dead… oh well…

So lesson learnt is not erasing hidden files unless you know what you are doing…


#5

But there are no hidden files on a usb drive that windows requires. So this sounds very strange. I have often deleted the mac files from a usb drive after transferring something.

Oh wait… I once did a similar thing many, many years ago and those files were for some auto startup stuff and some software for backup or decryption thing and that messed up the drive. I think I chose to format that one back then.

But you can try a dedicated software to recover some data.
https://www.easeus.com/data-recovery/data-recovery-software/free-sandisk-recovery-software.htm