"Heightfield" not working?

I’ve been exporting images, clipped from DEM’s in ArcGIS, in every conceivable format and bit depth, but Rhino does absolutely NOTHING after I run the heightfield command and select an image.

What is going on?? Are there size requirements for the image? Bit depth? Format? I can’t find any info about the specifics of the command on the McNeel website, other than a simple walk through.


Hello- please post an example image or send to tech@mcneel.com with a lonk back to this topic in your comments.


An example image of what? The even the smallest file (10mb) too big to upload to the forum and, as I’ve said, Rhino does nothing when I run the command, so it wouldn’t be useful to take a screenshot, would it?

Are there size requirements for the image to run the heightfield command? Bit depth? Format?

Hello - it would be helpful, in troubleshooting, to have an example of an image you are trying to use to generate the heightfield and which fails.


The input image you refer to in the first post of course. Send an example of the DEM through WeTransfer or dropbox or something like that. Or just zip it if that makes it small enough. That way Pascal can test for him self.

I presume the issue is caused by Rhino not supporting 32bit gray scale TIFF’s.

Yes, I would assume that also - first thing to try is if Heightfield will work with a normal image - just try it with any photo you happen to have on your computer first.

If you are trying to create a terrain model directly from the GEOTIFF image, that will not work. You will need some intermediate step, like going through QGIS and creating a point cloud from the image and importing it into Rhino, or using some plug-in that does accept GEOTIFF’s.

You could convert the image to an 8-bit Tiff. In Qgis there are options for 32 bit float to 16 bit float or integer values when exporting the image. I presume Arcgis can do the same and this should help you convert it to a useable value.

I’ve emailed Pascal.

Heightfield does work with other images, but nothing being exported from ArcGIS. I am able to change the bit depth (32bit, 16bit, 8bit, etc) settings for export in ArcGIS, which I’ve read in other threads is the problem, and/or export to .bmp, .jpg, etc. but nothing works. What’s even stranger is I have a college that IS able to do it following the same procedures.

I’m hearing and reading a lot about what Rhino heightfield CAN’T handle, but have yet to see any info on exactly what it CAN handle. So I ask again, are there size requirements for the image in heightfield? Bit depth? Format? Does anyone know? I can find a workflow to get the image to an acceptable format, but right now it seems like I’m throwing darts at a wall with no target, and shockingly, nothing is working.

I can easily create a heightfield from a 50+ megapixel 24 bit color .tif image (normal Tiff, not GeoTiff) with a mesh as an output and samples of 1000 x 1000. If I try using 7500 x 7500 samples, it takes a minute or two, but the 56 million face mesh does get created - it needs at least 12Gb of RAM during the process and 6Gb+ once it’s done.

If I try and make a surface from the TIFF at 1000 x 1000 samples I get this:

1 Like

Hi Sean - the image sent is ~ 55,000 by 40,000 pixels. That is roughly 2000 MB for an 8 bit image. Rhino is not going to handle that, I am pretty sure.
If you were thinking to make a mesh with one vertex per pixel, there is some logic there but as Mitch points out the mesh would be a little bit on the large side. If you can figure out how big a mesh you want, you can down sample to that so that you get a mesh vertex per pixel. It will be a lot smaller. I’m asking the developers now about what the maximum image size might be.


Aieee… If you made a mesh out of that - assuming you were able to export as a point cloud and try and import to Rhino - it would be a mesh with 2.2 billion faces… I know @Terry_Chappell is working with monster 100 million+ face meshes in Rhino, but that is 22 times that.