Heavy Blend Srf

Why when going from only 5 points to 4 points, does Rhino make such a heavy blend surface? Shouldn’t it be able to generate a solution with around, i don’t know, 7 points that satisfies the requirements at both sides of the blend?

complex_blendsrf.3dm (211.4 KB)


Hi Jonathan - you can get cleaner results by

  1. InsertKnot on the right hand shape > Automatic in U (so they match)
  2. MakeUniform


A blend surface can be only 5 control points in the transverse direction, but BlendSrf apparently does not have the logic to do so.

Loft between the edges of the surfaces to be blended.
ChangeDegree on the lofted surface. U to degree 5, V stays degree 3.
MatchSrf for curvature on either end of the new surface.
Result is as below.
complex_blendsrf_DC01.3dm (1.4 MB)

1 Like

After adding a uniform knot to the surface on the right, _BlendSrf will output a non-Refine version, but the surface is only G0 continuous on each side.


complex_blendsrf_NotG1.3dm (141.1 KB)

If you want alternatives to some of the built-in surfacing commands, please try My MatchSrf and EdgeSrf


Check the “Interior shapes” box in BlendSrf and the results are much better.

1 Like

I often prefer to use “Loft” followed by “Match surface” over the “Blend surface” tool for the exact same reason. Also, sometimes “Blend surface” will produce inconsistent flow which is most obvious with the Zebra analysis (no matter if the “Interior shapes” option is active or not). Not sure why “Blend surface” fails so often. It was more robust in Rhino 5, despite that its older version lacked the “Interior shapes” option.

1 Like