HDRI gamma limit at 0.2 why?

Hi guys, (@pascal)
I find many of the default HDRI’s too flat for dramatic lighting so I often adjust the Gamma for them.
But why is it a limit at 0.2?

See here how little difference there is between light and shade at that setting with the skStudio HDRI:

Here is the default values of the same HDRI:

So I would like to be able to set the Gamma value even lower than 0.2 to get more ompf :wink:

And why do you have both a HDRI Multiplier AND an extra Multiplier setting? It seems like they do the same thing. I would also like to have the Gamma setting on the main page for the HDRI. Could you please consider that?

This might be related.
I always find Rhino to handle the HDRI lighting as a low range light dome. Is there a bug there? As I can never seem to reproduce the HDRI lighting in any HDRI lights out there on the market.

This relates to both Raytraced and Rendered, so it must be at the core some where.

Take a look at this example image from HDRIHaven compared to how Rhino handles the same light. (That is not a sunny morning there in Rhino… it’s pretty dull and overcast if you ask me):

@nathanletwory do you know anything about what causes this?

Sunny Day Render.3dm (769.8 KB)

HDRI Image can be found here. I tried both the 8K and the 2K and no difference there.

I don’t know about Rendered mode, but for Raytraced I have a bug logged for this: RH-61976 HDRi with high dynamic EV are underpowered in Rhino Cycles.

Good, but it seems to be more than just underlit, it seems to be converted to a much narrower range.
If you compare the reflection in the chrome spheres in the image above you’ll see that in Rhino the sun burns out more too. And the shadows are way to soft. (At least I don’t think that an extra directional light is added to the HDRIHaven image, based on looking at other sample images from other HDRI’s from them)

Underlit is I guess in laymans terms what you describe (:

The HDRi with high EV should be equivalent to very bright sun.

OK, I think of underlit as using a too low multiplier. (Like underexposed on the camera side)

I changed underlit to underpowered in the YT item.

1 Like

:slight_smile: Use what ever you like, as long as you guys understand each other, I’m just a layman!

Keep in mind, Rhino is based in Seattle.



Norway and Finland this time of year are pretty much 24/7 dark.

1 Like

Yes, that’s probably why I am so eager to get some good artificial sunlight in the HDRI’s in Rhino :smiley:

RH-61976 is fixed in the latest Rhino 7.7 Service Release

1 Like

Yea! This has been a long time coming :slight_smile:

Thanks a lot!

1 Like

Hi guys, just did a test and This is very promising!
I had to set Gamma to 1.2 to get a descent result, could you check if it that is the correct setting, or if Rhino should adjust something to compensate for that?

Rhino 7 latest official SR at Gamma 1.0:

Release Candidate at Gamma 1.0:

Release Candidate at Gamma 1.2:


Just so you know, this regards Raytraced and not Rendered mode:

Here compared side by side with Gamma = 1.0:

And here Gamma = 1.2 for both views:

Before looking at the code I’m going to guess that using Gamma in the Output Adjustment section is going to cause clamping of the results - at least that is what it looks like to me, essentially removing high-energy areas if you used an HDRi with high dynamic range.

Disclaimer - I’ve never used the gamma setting in output adjustment. Any changes to textures I prefer doing outside of Rhino.

I’m not sure what you mean here, but all HDRI’s use Gamma = 1 as default as far as I know.

And my main point here is that Raytraced handles this very different from Rendered now after the changes that are made to this new SRC.

Now I don’t know what gamma you are talking about… The screenshots you showed in the beginning of this thread have you change the gamma in the output adjustment section of the hdri texture in the environment.

Is this not the gamma you are referring to?

Oh… right, I never really paid any attention to the taps sub section names… :expressionless: I just scroll down and adjust it, sorry about that.
I thought you were referring to some post effect or rendering output setting. My bad!

I understand that this is confusing because now I am trying to replicate it on another machine with a different HDRI and here the lighting looks the same in Rendered and Raytraced, so I need to double check that both display modes uses the same settings for background etc. (that stuff isn’t 100% intuitive so I might have changed something)

But now on this machine when I lower the environment hdri strength then the Raytraced viewport background is darker than the Rendered background:

Here I used Background = Use Render Settings for both.
If I select Use Application Settings then the Raytraced mode is still darker than Rendered:

But the lighting and the shadows from the HDRI are really nice and crisp though! So thanks for that great work!