Grid Snapping Default Behaviour


#1

Hi,
I’m new to Rhino (I’ve used 3DS Max and Maya before). Maybe someone would be kind enough to walk me through this. It’s probably just what I’m used to in other 3D programs and perhaps the thinking is perhaps different here.

Part 1:

  1. I only have grid snap on.
  2. I relocate Gumball to some location on my
    geometry.
  3. I’m expecting when I use grid snap for my object to snap
    based the center of Gumball to the nearest grid location.
  4. Instead it snaps the selection over one grid unit over (see the attached image).

It’s fairly easy to get around using OSnaps. Is there a way to change this default behavior or should I just get used to it and stop thinking like I’m using Maya.

Part 2:
Supposing I set ‘Control Points On’ and I select a group of points.
a) How can I move them using the Gumball tool to collapse onto a grid line?
b) Is there a way of toggling this behavior of the Gumball tool (i.e. keeping the sub-component spacing)?

Thanks,
André


(Pascal Golay) #2

Hi Andre- if I understand you, use GumballSettings to change to SnappyGumball=On for part 1… and use SetPt rather than gumball for part 2.You can also type a scale value of 0 in the square gumball handle (scaling) in the direction you want to collapse the selected points. Is anyof these on the mark?

-Pascal


#3

Thanks that worked great. Now I can go about repairing the hole I scratched into my head trying to figure out where the option was. It seems so obvious in retrospect. Sometimes the hardest part about learning a new modeling package are figuring out the little things.
I’m really enjoying the precision I can get with Rhino, it’s just great.


(Pascal Golay) #4

Untrim.

-Pascal


#5

Really I LOLed :::)))