Grid becomes shaded

Grid Ports.3dm (3.4 MB)
When I go from wireframe to shaded mode, the grid becomes shaded as well as the solid, instead of remaining as-is. I must have toggled some setting inadvertently that I have no idea how to reverse now. Grid Options, Viewport Options, and Display Options don’t seem to hold the answer to keeping the grid intact, which is what I’m asking for help with.

Hello - see if restoring the defaults for the Shaded display mode, in Settings > Display Modes > Shaded, sorts it out.


Thanks for trying. You did mean Viewport settings, right? I got the grid back to normal but then that strips the shading off the solid as well. But there’s something interesting going on; the Front and Right ports behave as they should—it’s the Perspective and the Top with the problem, and I don’t detect what makes the difference. I included the file so you can poke at it directly if you have the time for it.

Grid Ports.3dm (3.37 MB)

Hi Eric -

I don’t think there’s something in that file that is doing things. It opens fine here:

No, if you have modified a display mode, you can reset it to the defaults:

Also, please run the Rhino SystemInfo command and copy-paste the result here.

Thanks for trying to help. I’ve clicked around now enough to make my finger sore, and nothing works. I can’t get past this.