Grasshopper's custom preview broken in Rhino 8 WIP?

For me it appears that the custom preview component is broken in the Rhino 8 WIP. I can no longer get the component to display other colours for curve inputs.

This is on Windows 10, 19045, Rhino version: 8.0.23220.12305, 2023-08-08

I’m on Rhino 8 SR0 2023-8-15 (Rhino WIP, 8.0.23227.12305 and it seems to work fine.

On my end it doesn’t work either.

I assumed this was a deliberate split of the logic where users now need to use the “Custom Curve Preview” component for all curves and the “Custom Preview” component only previews geometry now.

But if that’s not the case then it’s a repeatable bug on my end as well.

I’m on the 2023-08-15 build as well @martinsiegrist .

Graph Space 01:
image

Model Space 01:
image

Graph Space 02:
image

Model Space 02:

So when the curves are Rhino are hidden, you don’t see anything?

Correct.

Here’s what it looks like on my end:

Preview Selected (Off) (Input Crvs Visible:
image

image

Preview Selected (Off) (Input Crvs Hidden):
image

Weird. So why is it working for me?

linetype.gh (21.8 KB)

I hope the baking bug is fixed on Wednesday so I can continue working.

Because you are using the Custom Preview Line component :upside_down_face:

Your Custom Preview is disabled and your Custom Preview Line is enabled.
So the blue lines are not from the Custom Preview component.

And yes, the bake bug decimated my scripts haha, looking forward to that being resolved as well!

Ohhhh it’s the Rhino Viewport Display Mode… It shows up in all Display Modes except for Rendered & Raytraced:

I have been in Rendered View where the curves input into the Custom Preview component will not show up.

@wim @brian can we get a bug tracker on this item? “Custom Preview component does not display curves when in Rendered or Raytraced view mode”

Custom Curve Preview…

@Intuos what version are you running? Can’t be the most recent since you’re still having Custom Preview Materials and Custom Preview Lineweights components…

Actually those are from Human:

image

image

1 Like

Ok so now I see a problem too. Preview disabled, curves visible in Shaded mode but nothing shows in Rendered mode.

1 Like

Correct!

Thanks. I knew I’ve seen these icons before…

Rhino 7:

Rendered mode shows the surface despite preview off. Shaded mode shows nothing.


Rhino 8:

image

Rendered mode, nothing shows despite Render checked.

preview_problem.gh (7.3 KB)

image

Here it says Wireframe but I see no problem in Wireframe mode…

I think I have been having this issue for a little while now (for at least a month and a half), as you can also see that referenced curves are not displayed in red either. I’m indeed on wireframe mode in these test files and I know custom preview used to work in rendered or artic view before in the Rhino 8 WIP.

It’s been in various states of working on different view display modes for me as well for I believe yes about 2 months or less

Yeah, before that it definitely worked fine. I haven’t done much Grasshopper work in the month or two prior, but when I started again, the issues also emerged - though they weren’t there before.

It’s also at the point where if I select the geometry preview component, it stops displaying stuff.

And when I select preview only selected components, then it does show again when I select the component…

I have also been having issues in general of seeing the default red and green (selected component) previews.

I’ve added RH-76903 Custom preview ignores render checkbox

@Intuos I cannot reproduce the issues you are showing in your videos. A file that shows this behavior is needed.