Grasshopper won't start / Ladybug+Honeybee errors


After my company did some Windows updates my Grasshopper won’t open, crashing Rhino 7.

It always gets stuck loading Ladybug or Honeybee User Objects.

So far we’ve tried the following to fix but with no luck:

  • Update Rhino 7 to latest version
  • Delete all User Objects from AppData/Roaming/Grasshopper
  • Add Ladybug/Honeybee User Objects from a working Rhino 7 on another PC

I also looked into Ladybug/Honeybee removal tools - can’t use those as my Grasshopper won’t start.

Would love any suggestions or advise on how to solve this.

Hi -
Does Grasshopper start when all Ladybug and Honeybee user objects are removed?
If this is strictly limited to those tools, you might want to look at for information.

Hi Wim,

Thanks for responding.

I tried deleting all Ladybug and Honeybee User Objects but that did not solve the issue.

I am assuming this is to do with Ladybug/Honeybee but it might not be.

Is there step by step guide or something to completely clear all 3rd party Grasshopper plugins from my PC?

Hi -

No - there are several ways of getting plug-ins to run in Grasshopper. You’d start by uninstalling anything that is installed by the PackageManager and then delete files from the Grasshopper special folders.

Try the _GrasshopperLoadOneByOne command.


1 Like

Thanks @wim @kev.r

Running the command Kev R suggested helped me to get into Grasshopper and start troubleshooting.

I have nothing installed by the PackageManager

Now, I have deleted all 3rd party component files in AppData/Roaming/Grasshopper but when I try to load Gh it still attempts to fetch Honeybee from somewhere else.

What are the paths I should check for any remaining plugin files? I also have Rhino 6 installed.

Hi -

When you start Grasshopper with the GrasshopperLoadOneByOne command, the path to the plug-ins will be stated in the dialog box.

1 Like

You can find the locations of grasshopper special folders by going to FileSpecial Folders from the grasshopper menu.

You should be able to uninstall anything you’ve installed with package manager from the _PackageManager command.