Grasshopper Player hooked

I had Version 7 SR11 and have upgraded to: 7.11.21293.9001, ( 7.12.21292 is latest release candidate).

Actually it improved the performance, but not fully solved the problem. I’ll wait for regular release fix then.

Thank you¡

Hi there,

I’m having the same issue. Tried to find a solution but all i found, was several people reporting the same problems.
My conclusion so far is, it only happens only when Grasshopper has been open since I started Rhino.

Here are other posts for this problem:

How to close or disable grasshopper player preview after use? - Grasshopper - McNeel Forum

Is there a way to get someone from McNeel to have a look into it? They thought they’ve fixed it with an older release, but it still exists.

Thanks for your help!

I bypass redraw, so preview is set to off
and Yes should by fixed as quickly as possible.

Hi -

As you might have seen in related threads, we have looked into this but haven’t been able to reproduce the issue. I’ve been trying again now, using different versions of Rhino on both Windows and Mac, using several of the definitions that are referred to in those threads. I can’t make this happen. If you have detailed steps and a definition, I’m happy to try more…
-wim

1 Like

I created a simple file. To reproduce follow these steps:

  • start rhino
  • draw some geo
  • start grasshopper player and follow the steps
  • do it twice with different numbers or different geo
  • now start grasshopper => the ghosting starts

Me with clean Rhino and Grasshopper Player:
only the actual choosen objects are previewed

open grasshopper - an all the last states are previewed (thats what I mean by ghosting):

Grasshopper Player used again: third set of objects to be seen:

To lock the solver didn’t help. Closing grasshopper doesn’t help. Only closing and reopening Rhino helps.

I hope with this instructions you’ll be able to reproduce the problem?

I’ve got version 7.12 Rhino (Rhino 7 SR12 2021-11-9 )

ghosted_preview.gh (6.5 KB)

How do you bypass it?

Hi Jess -

I’m afraid not, no.


-wim

even with different preview options it’s like this with my RH

First I thought it’s because I usually don’t use a context bake and just jump out of the process.
Or because of the use of certain plugins…
Or because it doesn’t like blocks…
But neither exclusion helped.

But i’ll keep trying. As soon as I might find something, I’ll let you know :slight_smile:

@wim
Open Rhino (here 7.13)
Open Grasshopper and close Grasshopper
Run GhPlayer (example by Jess) definition
and other when values are entered, there is not automatic redraw refresh, except when I click in the window.
Ghost

@interkinactive
Preview was set to off, value input does not generate visual feedback, sadly
ghosted_preview.gh (6.4 KB)

Hello Wim,

I set a relevant example using only python script in this thread :

I made a GrasshopperPlayerOnce Rhino command if you need. Have a look here:

By the way, for a V2 I succeeded to adapt the c# script in a ghpython, it would be great to make a python script directly. If the issue is not solved until then :smiley:

Hello, the problem of ghosted preview is related to Remote Control Panel
If you close it from Rhino or Unselect it from Grasshopper > View the ghosted preview disappears

1 Like

Confirm it here, thanks @seghierkhaled
But there is not automatic redraw refresh,, example when i enter new distances then for display refresh I need to move the viewport briefly.

I think that the developers must do something with RCP and fix this error

Try this simple code with python and plug it to the output

1 Like

@seghierkhaled ok, tested, nothing happens without moving viewport.
Worked, i forgot brackets, painless solution, thank you :+1:

To avoid ghosted preview without close RCP

image

Hi @wim

I am having the same sort of issues. A sort of memory caching of geometry which I would not expect.
In the video below you can see the following steps:

  • Grasshopper player starts grasshopper command “place block”

  • This component uses “get-line” input for placing, and the “geometry pipeline” for reference geometry.

afbeelding

  • The command runs fine and generates a line with info to generate the geometry.

  • The unexpected thing starts after the grasshopperplayer has run succesfully and is finished. When I move a road line (the referenced geometry) a lot of place block geometry is generated without giving a new command. Somehow the geometry of the geometry pipeline is cached, and when it is changed it invokes new running of the command.

ghplayer

Hoi Erik -

This issue is on the list as RH-66768 and was fixed in the WIP on Windows by providing a setting at the bottom of the Document Properties dialog in Grasshopper:

That issue is still open because it hasn’t been implemented on macOS yet.
HTH,
-wim

2 Likes

Hi Wim, this option is very useful, please consider to allow the remote panel when running grasshopper player too.