Grasshopper not seeing components

Thanks for the reply David,
I replaced CSVReader.gha with CSVReader.no6 and entered GrasshopperLoadOneByOne which resulted in another Grasshopper Breakpoint error message, this time with a different component. After after replacing the following components with .no6 based on the newest error messages [CSVReader, MooSolutions, Sampling and Screen Capture] , the GrasshopperLoadOneByOne command worked. I clicked a lot, and all the components were showing.
Grasshopper also loads now with just the Grasshopper command. Does this mean for the time being I will not be able to use these components in Rhino WIP?
Thanks again, t

Looks like it. It would be nice to know why these components are failing to load. Can you upload one of them here so I can test using the exact same files you have?

Sorry for the reply, I didn’t see your message earlier.
I am having trouble uploading the files to the forum because ‘I do not have permission’ form the developers.
I will email them and ask for their permission to do this so that either they can email them to you, or I can share a copy. At least they will know there is a problem.
Thanks again for the help. t

Hi,
I encountered the blank canvas issue today. After this message was shown in Rhino 6, Grassshopper appeared with no component.

What should I do to retrieve the lost components?

Remove hoopsnake I think

Hi Michael,

I removed Hoopsnake but the basic components still does not show up.
I am not sure removing Rhino 6 and reinstalling it will help, but I will try that.

T.Vo

I am also having this problem! would you mind taking a look?


Command History:
Loading Rhino Render, version 1.50, Nov 18 2019, 20:55:09
Command: Grasshopper
Command: '_Paste
Command: _GrasshopperDeveloperSettings
Command: _GrasshopperDeveloperSettings
Command: '_Paste
Command: _CommandHistory
Command: Grasshopper
Command: '_CopyToClipboard
Command: '_Paste
Command: _CommandHistory
how can i get this issue solved?

Can you run the GrasshopperLoadOneByOne command and just say ‘no’ to all plugins. Then slowly bring them into the fold until it fails?

There was no option to choose

The LoadOneByOne command asks before loading each plugin. You can choose to either load it or not. If it doesn’t show a string of message windows something is going very wrong very early in the loading process.

What exactly are you seeing after running the Grasshopper or GrassLoadOneByOne commands?

This pops up first thing after trying the grasshopperloadonebyone command

Hi all,

I am seeing the same problem with an error and blank GH toolbar. I just tried the Rhino 6 install (first time - I’ve had Rhino 5 for some time now) and it seemed just fine. But when I run Grasshopper in Rhino 6 I get an error and a blank toolbar?

When I run ‘GrasshopperLoadOneByOne’ I get the exact same result as when I run “Grasshopper” (it doesn’t ask me anything, just gives the error and goes to a blank toolbar). My error shows:

I have no idea where _excelreadwrite.gha is though? Its not in my ‘Components’ or ‘User Object Folder’? Its some old plugin I’d downloaded and tried back in Rhino 5 months ago but I thought I’d gotten rid of it ages ago.

when I try “GrasshopperDeveloperSettings” and show the valid folders, I get only two folders:
42%20PM
(note its all inactive, can’t click or add folder or so anything in that window)

Those folders its pointing to contain only:
38%20PM
and
09%20PM

nothing called ‘excelreadwrite.gha’ ? I did a HD search as well and nothing came up with that filename anywhere on my system.

any thoughts on how I can clear this out of my load sequence and get GH to work correctly? Any advice is much appreciated.
thanks!
-Ed

Can you run a full search on your entire drive for all files with a GHA extension?

In the meantime I’m looking into what might be causing this exact error.

As a test, can you move all the files and folders from the C:\Users\edpma\AppData\Roaming\Grasshopper\Libraries into a folder elsewhere and try loading again?

Note that both @Kevin_Saslawsky and @ed.p.may errors are regarding plugins with a dot-underbar prefix, i.e. ._HoopSnake.gha and ._excelreadwrite.gha respectively.

This indicates something strange is going on. Apparently this prefix is associated with shared volumes… link1, link2

So searching a local disk may not in fact suffice…

1 Like

Hi @DavidRutten,

Thank for your response.

As you suggested, I went back and did a more thorough search and was able to find that ‘underscore’ file after all (in my case, _excelreadwrite.gha). Turns out it was a ‘hidden’ file inside my .../AppData/Roaming/Grasshopper/Libraries/... folder.

It must have been created / added by the plugin somehow and when I removed the plugin’s unhidden .gha file from that directory, that ‘hidden’ file stayed behind.

Once I removed that ‘hidden’ underscore file from my library folder everything in my new Rhino 6 Install booted up normally and successfully.

thank you!
-Ed

1 Like

Thanks. Glad it’s working, but it’s so weird that it messes with the loading sequence to such a degree. You wouldn’t still have that file so you can send it to me?

You bet: it was still in my trash. I’ve attached it here for your reference.

._excelreadwrite.gha


best,
-Ed
._excelreadwrite.gha (4 KB)

1 Like

Hi, the same problem is here. My rhino is version 6 and my Grasshopper components are not shown. Last day I installed some plugins and today I cannot use any plugins


I need help, please

@DavidRutten Please would you kindly take a look at this ?
It is similar to all of the above, which I have read and attempted, but it doesn’t work for me.

I’m on Windows8.1. I’ve tried de-installing Rhino and reinstalling it again. I’ve tried moving the contents of >Libraries out elsewhere- doesn’t work.

I’ve tried to _GrasshopperLoadOnebyOne. This opened grasshopper without the error message - but still none of the components are there - all blank.
See images below as well.


Please could you help, perhaps you can see what is wrong?

With hope…
Alex