Some Basic Components Missing after a Normal Startup?

Hi all.
I was working on a file yesterday, and when I opened the file today, it is telling me that some basic components are missing, and the package restore function doesn’t work for reinstalling these components (see attached imgs). WeChat Screenshot_20200906160704 WeChat Screenshot_20200906161308

I made no change to the computer or Rhino/GH before the issue appeared.
Could I get some help with this? What’s going on and how can I get the components reinstalled?

Many Thanks.

Anything in the Rhino command line history after you run the Grasshopper command?

Hi David. No, I don’t see any, other than a T-spline warning that I think is irrelevant. Here is a screenshot of starting GH before the unrecognized objects window pops up.

hmmm, still haven’t figured it out. Any suggestions/ideas anyone?

Considering TSplines doesn’t work for Rhino6, try removing anything associated with TSplines from your machine.

CurveComponents may be missing?

Not to beat a dead horse, but there’s nothing above that T-Splines error? I.e. if you run the _CommandHistory command and scroll up to the point where you see _Grasshopper there’s nothing?

Can you also click on the little black plus sign in the top left corner of the Grasshopper about window and show me what it looks like?

Checked, Curve Component.gha is in the folder.

Thanks for double checking. Here is a screenshot.

Okay thanks. Next check is to start Rhino afresh and run the _GrasshopperDeveloperSettings command and click on the Valid Folders button. It should list all the folders from which plugins will be loaded. I’d like to see that list, mine looks like this:

Then, instead of _Grasshopper, run the _GrasshopperLoadOneByOne command. Does the CurveComponents.gha plugin make an appearance? It’s the first one I see on my machine.

Thanks David. See attached. GH Valid Folders

And no, CurveComponenets.gha did not make an appearance when I ran _GrasshopperLoadOneByOne

And that folder it’s in is one which appears in your Library Folders list?

Would there happen to be another file in the same folder called CurveComponent.no6? Plugin loading will be disabled quietly if such a file is present. It’s the only thing I can think of which might cause this without any error messages popping up.

1 Like

Hi David. Thanks a lot. That’s it. Solved. What is that file by the way? Should it always be deleted when present?

It’s specifically designed to stop a GHA plugin from loading on Rhino6. In case there’s plugin versions specifically for Rhino5/6/7 and they don’t mingle.

I’m not sure how that file was made, it is usually done by hand, but it will also be created if you click the “Never Load This Plugin Again” option on the startup warning window.

1 Like