Grasshopper not intalling


I was wondering if someone might be able to help me with an installation problem. I am using Rhino 4.0 SR9 and have downloaded the old grasshopper edition. The program shows up in C: and when I go to options > rhino options > plugins it shows up but says it is not loaded automatically. When I try to load it manually it still does not work because of the error message listed below. I have also tried all the other easy basics like reinstalling grasshopper a second time, dragging the plugin into Rhino, typing grasshopper into the command line…

Anyways, when I try using grasshopper, I get the following error:
"Exception occurred in plug-in Grasshopper
Unable to Load DLL ‘rhcommon_c’: The application has failed to start
because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (Exception from HRESULT: 0x800736B1)

Stack trace:
managed_type_name, Guid managed_type_id)
at Rhino.Runtime.HostUtils.initializeRhinoCommon()
at Grasshopper.Plugin.GH_PluginUtil.LoadGrasshopper() in
C:\dev\Grasshopper\1.0\root\src\GH_GrasshopperPluginUtil.vb:line 33
at Grasshopper.Plugin.GrasshopperPlugin.OnLoadPlugIn()

Thanks in advance for the help and suggestions! :smile:

If I remember correctly, you need to update your windows to include the latest VC redistributable and also DotNet framework.


Thank you, @Helvetosaur . I already have the DotNet framework in the latest installed version. As for the VC redistribute… I have just downloaded without successfully changing the error message when trying to use Grasshopper. Do you have any more suggestions…

Thank again!

Nope… Back when the same version was being used by both V4 and V5, I found installing V5 usually fixed the problem for V4 because the install updated the necessary files (no idea which). Now that the versions are separate, that may no longer be true, but if you have not already installed the trial version of V5, you might give that a try.

Also, I assume you read this article…?


Thanks @Helvetosaur! I had installed the wrong VC redistributable. This is the correct link:

It works now! :smile: