Grasshopper missing in the tools menu

Hello, I recently installed Rhino 6 on a mid 2012 13" macbook pro running catalina. Rhino is working fine but grasshopper is missing from the tools menu. The grasshopper files icns are present in the resources folder…
Not sure why this is happening. Any ideas?

Hi - what happens when you run the Grasshopper command?
Please also run the Rhino SystemInfo command and copy-paste the result here.

Thanks for the quick reply.
When I run Grasshopper i get: Unknown command: Grasshopper

Here is the system info:

Rhino 6 SR24 2020-3-19 (Public Build, 6.24.20079.23332, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Commercial, build 2020-03-19
License details: Stand-Alone

Apple Intel 64-bit macOS Version 10.15.4 (Build 19E287) (Physical RAM: 8Gb)
Mac Model Identifier: MacBookPro9,2
Machine name: Katya’s MacBook Pro
Language: en-GB (MacOS default)

Intel HD Graphics 4000 OpenGL Engine (OpenGL ver:4.1 INTEL-14.5.22)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel HD Graphics 4000
Displays: Color LCD (114dpi 1x)

Graphics processors
Intel HD Graphics 4000 (1536 MB)
Color LCD (1280 x 800)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins
/Applications/ “PanelingTools” 6.24.20079.1002
/Applications/ “Commands” 6.24.20079.23332
/Applications/ “Snapshots” 6.24.20079.1002
/Applications/ “RDK_EtoUI” 6.24.20079.23332
/Applications/ “Displacement” 6.24.20079.1002
/Applications/ “Renderer Development Kit” 6.24.20079.1002
/Applications/ “Rhino Render” 6.24.20079.1002
/Applications/ “RhinoCycles” 6.24.20079.23332

Hi - did this start happening after a while or has it been like that since you installed Rhino?
Is Grasshopper present in the list when you run the PluginManager command? If so, is it loaded/enabled?

Just installed few days ago. Basically first use today. Grasshopper is not present in the Plugin manager

Hi - I haven’t run into that one yet…
Could you download and install again to see if that changes anything?

I tried reinstalling. Maybe I should delete the app and install again?

It wouldn’t hurt trying that.

Redownloaded the file and installed after deleting previous installation. Grasshopper is still missing.
Do you think i need to clear preferences and such?

Also should there be a Grasshopper rhp file in the plugins folder?

There should be a GrasshopperPlugin.rhp file in the ../Resources/ManagedPlugIns/ folder, yes.
Did you previously run Rhino 5 on that machine or is this the very first time that Rhino gets installed?
Clearing preference also doesn’t hurt to try but unless there’s something left behind from earlier attempts, that probably doesn’t help all that much.

It’s my girlfriends laptop. Clean install after SSD upgrade.

Now I checked the installation on my mac also doesn’t have the file GrasshopperPlugin.rhp but it works. In fact no ManagedPlugIns folder at all.

That’s probably got something to do with the way I “install” Rhino on a Mac.

At any rate, I’ll ask around if anyone has any bright ideas about this one.

Thanks a lot. Appreciated!

I now tried copying the app from my laptop, where it is working to her laptop, but it didn’t help still.

Hi again - this might have something to do with licensing. Plug-ins such as Grasshopper don’t run on installations of Rhino that have either expired or have not been validated. Have you gone through the complete validation process?

(As for that “ManagedPlugIns” folder - I’m told that MacOS will hide this folder from you and that the Finder app won’t find it…)

Ah that was it! I redid the validation and now it’s working!

Thanks for you help @wim!

1 Like