Grasshopper Gives wrong extension when downloaded


#1

I just downloaded GH and the file downloads as a zip file which you can open but then nothing in the zip file shows an install file to click on, which might lead one to think that they have to install the files manually. What a drag that would be.

I don’t know how many people know they have to change the extension to .rhi and not zip, I read it’s windows that is doing this by searching this site but the fact that McNeel doesn’t warn you of this anywhere is another place where the ball is dropped. When one downloads the page should say warning extension on file might download as a zip file if this happens change extension manually to .rhi

Please post a fix for this and let the community at large know that this might happen not just show the fix in one tiny thread accessible only on this list, better would be to figure out how to get your extension of rhi to be noticed by windows so that it actually works without user intervention.
RM


(Pascal Golay) #2

Hi Roland- I see rhi as the extension when I download here- I just tried it… Hmmm- at what point do you see the file name as .zip?

-Pascal


#3

Hi Pascal,
After I download it the file says .zip and I have to change the extension to .rhi . Also I read the post about this on this forum which was about windows changing the extension to zip, did you see that post?
Thanks for taking a look, this looks like something that needs tuning.
RM


#4

That’s a security feature of Windows/Internet Explorer. Probably no way around it.

For most of the users to rename files to the “proper” extension is a pretty good idea as most trojans are just executable or extractable files with renamed file extensions.


(Steve Baer) #5

@brian, I thought you had a way to adjust the server response header so this wouldn’t happen.


#6

My point is that McNeel doesn’t tell a user to rename the file unless you find the post about it on this web site. Notice Pascal who works at Mcneel didn’t know of the post. McNeel needs to tell users about it in the first place and it should be fixed so it works.
Also most systems scan downloaded files regardless of extension name anyway so I don’t really see why renaming is so kosher or would save you from trojans. The file opens as a zip file where you can see all the files inside anyways who would know if that was not a trojan in fact it seems more wrong to rename when the zip extension is not the proper one to begin with.
RM


(Pascal Golay) #7

It is inconsistent here as well- my IE lets me save as rhi and does not suggest zip, but Mitch’s wants to call it zip by default.

-Pascal


#8

Interesting… It seems to work just fine on either Chrome or Firefox… With IE however, seems to vary from person to person, just tested, here on my laptop with IE11 it downloads as a .zip, but I’m sitting next to Pascal today and on his machine with IE11 it downloads as an .rhi… Odd.

–Mitch


(Steve Baer) #9

Ok, my last comment was probably very cryptic to most people reading this thread. I believe there is a setting we need to adjust on our server that will fix this so IE won’t change the extension. It is not something we expect users to know about or have to research to find the answer to.


#10

To be fair to Pascal, it’s not a commonly know fact as it doesn’t present as an issue to everyone as there are lots of Internet Browsers to choose from*. It was only posted here the other day as it was my first “real” look at the new McNeel discourse forum. That being said it wasn’t even the answer to the problem at hand.

I think Grasshopper knowledge and support still resides with the user base. Maybe now that Rhino 6 is taking GH into the fold -which was a shock to all- things will change. But certainly at present the best place to find help is at www.grasshopper3d.com

There are many users here that post over there but if you are looking to search for answers you might have better luck.

As information like this is only as good as its discover-ability can you tag this post with the Grasshopper Category so that others may find it.

*Internet Explorer the best browser by far for downloading Chrome or Firefox


(Brian Gillespie) #11

Hi Roland, this is now fixed. The Grasshopper installer RHI got uploaded incorrectly; I’ve fixed it and now it should be totally compatible with Internet Explorer.


#12

Hi Brian,
That was fast thanks for fixing this.
RM