Grasshopper fails to reference elements from Linked Files

Hi there.

Couple of months ago in May 2021, I used to have my grasshopper definition reference elements inside linked files in the Rhino 7 document. For example, test-file-2.3dm has a linked copy of test-file-1.3dm (block definition type: linked, Layer style: Reference), and the grasshopper definition is able to reference individual elements in test-file-1.3dm by referencing the linked file’s layers using the Human plugin’s Dynamic Geometry pipeline or the default Geometry Pipeline component. Elefront’s Reference by Layer component works too. I’ve done this for about 20 of my definitions.

Fast forward to Jan 2022, and a few updates to Rhino 7 later - I opened up a few of the old rhino files and grasshopper definitions to find that this no longer works. Human, Elefront, and default Grasshopper now seem to be unable to recognise individual elements in Linked Files. What appears in place, are InstanceObjects/Referenced Blocks.

Does anyone face the same issue, and are there any solutions? I’ve been able to replicate it on a fresh install of the latest Rhino 7 on a fresh install of Windows. Have also attached the files I used to test this.

Rhino version: 7.14.22010

block link test.gh (15.0 KB)
test-file-1.3dm (154.8 KB)
test-file-2.3dm (163.6 KB)

I’m not quite following. This seems like the expected behavior when referencing a work session or linked block. If you are looking for the Brep inside the Block you would need to deconstruct.

I would expect that as well, except that it worked previously. I could simply insert an external 3dm file as a linked block, and Grasshopper would be able to recognise individual breps inside the linked block. This was my workflow for the whole of 2020.

Would it be able to add this as a feature request?

I’m failing to come up with a workflow that would allow this. I’m curious on how this was working for you in 2020.

I’ve just checked all my grasshopper files from that period of time and have confirmed that they were all using this workflow. Very strange.

Is there a way we can download older versions of Rhino 7 to give it a try? I recall I switched to Rhino 7 almost immediately after it was released - so perhaps version 7.1.20343?

This workflow would be fine in a worksession.

I’ll send you that version in a private message.