Preview with Material conflicts with "rendered view" shadows

Hi Andrew,

I noticed that using your (amazing) box mapping and preview material components leads to a weird effect when looking at geometry in the rhino viewport with “rendered view” on. Namely, the shadows from existing geometry in Rhino overlay the textured elements coming from GH.

I tested if it’s my render settings, reset the view settings, tried VRay as renderer, and tried a normal “custom preview” component with a material from within Rhino. It seems to come specifically from your component.

Ever encountered that problem?

Thanks,
OD

The way Grasshopper plays with the “rendered view” is a fairly new invention… it’s newer in fact than the custom preview material component itself. I have not had the time to look into how this render pipeline works or to update the component accordingly… so I am not surprised it doesn’t play well. Unfortunately I doubt I will be able to fix this any time soon.

Somehow it helps adding a normal “custom preview” component to the geometry output. Even when turned invisible, it gets rid of that error!

Weird, but works :slight_smile:

Hello Oliver,

It’s been a long time since you created this post but since I face a similar problem I’d like to put it here.

This is what I’m experiencing.



Is there any kind of fix? Sometimes in a document I have a couple of Custom Display components and it takes time to shut them all one by one…

Hi - not a solution and I might be misunderstanding - the last image and the text underneath somewhat contradict.

Turning off the object preview on the Custom Preview component turns off the preview in non-rendered display modes (Wireframe, Shaded, …) but still previews in rendered display modes. You can make it so that it also turns off the preview in rendered display modes by unchecking the Render option.
image
-wim

Hi Wim. That was what I meant and your comment solved the issue. Thanks a lot.