Display problems in Grasshopper

I have display problems when using grasshopper. I use the component “custom preview” with a shader to represent the wall and the ground of my building. I use the “ladybug recolor mesh” to display the results and the mesh. I turnt Rhino and grasshopper off several times and that didn’t change anything. Same with the bump preview. When i zoom in and out, it moves a lot (not in a normal way). Can someone help me with that ?

  1. no file uploaded.
  2. you cull faces of the mesh and the rest is displaying green. Looks right for me. How it‘s supposed to look?

Hi Tim,
I didn’t upload it because it’s very big. Here is the file cleaned ( with enough elements to see the problems)
The walls and the ground are supposed to be straight . The part in green are supposed to follow the pattern of the mesh (squares)
script.gh (1.4 MB)

If your geometry is very far away from the world origin (0,0,0) then mesh display will be very inaccurate.

Think of the numbers are only having a small amount of digits and a variable period position. So you can either have a small number with high accuracy: 2.634872 or a big number with small accuracy: 263487.2. If you really push it you’ll end up with exceedingly inaccurate numbers such as 2634872000000.0 where the ‘gap’ between the nearest two adjacent numbers is very large indeed, about a million in the last example.

Keep your geometry medium sized (somewhere in the 0.01 to 100000.0 range) and close to the world origin to avoid display and other accuracy problems.

Thanks a lot for your answer. I moved everything closer to the origin and that worked well.
I have a second display problem though. The 2 pictures are exactly the same but i just moved a little bit the angle. It looks like a weird wireframe display whereas it’s supposed to be a shaded display.
On the picture the walls on the building in grey are displayed in Rhino and the walls in white are in grasshopper. The display in rhino seems good but not in grasshopper.
I’ve had a similar problem in another model also.
Do you have any idea to correct this ?


Are you on Rhino5 or Rhino6? If you’re on R5 then you can try and disabling the z-bumping from the rightmost button on the canvas toolbar. If you’re on R6 the bumping doesn’t happen so something else must be the problem.

Im on Rhino5.
I’ve tried this bump preview button a few times and that didn’t work until now… that’s great, thanks a lot :wink: