Grasshopper component error

Greetings,

I’m getting this error when opening grasshopper component (version 1.3). I have evaluation license for rhinoceros 8, any idea what could be causing this?
error

tekla

Hi Egidijus,

It seems to be because of the fact that Rhino 8 uses .NET core rather than .NET framework. Check this post on how to remedy the situation:

Cheers,

-b

2 Likes

Thanks for quick response.

The error that appeared at first is now gone but I’ve got another one now:

image

Looks like linking problem but it in grasshopper, I can see it uses the version provided by your reply post.

image

The file in components library isn’t locked:

Any ideas?

I assume the dialog in Tekla remains unpopulated after closing the warning, but can you still click the pen button to open the script in GH from the dialog?

image

Is the Tekla tab visible in GH? What does the definition look like? Something else missing than the Tekla components?

Cheers,

-b

After clicking “OK” on the error, I do see the Attributes and input window:

If I click on the “Open definition…” button, I get this:

image

Yes, tekla tab is visible in grasshopper, I don’t have many other components but the ones I do, seem to be there.

Hi, so the plugin works except for those messages then?

Here’s a small update that should show which grasshopper libraries are currently loaded when it claims that the Tekla link isn’t installed, shows up in the same message box:

https://drive.google.com/drive/folders/1ASnmQUpP7rkC7vjthVTFF9nGkvJyfOz_?usp=sharing

Check what this says when you have a chance. You probably need to uninstall the previous version with the Extension Manager in Tekla first.

Cheers,

-b

It worked now.

I think the 1.3 version plugin uninstall was stuck and didn’t uninstall it properly since I had to kill everything associated with Tekla in task manager.

I did start getting the crashes with the GhPython.ga, after removing it, no more crashes or anything.

Thank you very much!

1 Like

Alright thanks for confirming, then we’re down to the errors I can actually replicate :sweat_smile: We’ll see if we can tackle those as well in the near-ish future.

Cheers,

-b

1 Like

Hi there,

I’m having the same issue as in Egidijus first post, though I haven’t installed Rhino 8. The only difference that I can think of is that I have been starting out with C# development and there may have been some .NET installations.

I tried the 1.4 plugin, but it complained that Tekla Live Link 2023.1.16 wasn’t installed. This version isn’t available yet.

Do you have any advice?

Tried removing Tekla Live Link and GH-component and reinstalling, but I’m still getting the same error. @sebastian.lindholm : Do you you have any ideas?

Reinstallation of Tekla did the trick :slight_smile:

1 Like