Grasshopper break point error?

need help :wink:

Hi Paul -
Are you using any non-default Grasshopper plug-ins?
Also, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR22 2022-9-12 (Rhino 7, 7.22.22255.05001, Git hash:master @ 196b1bc7dd093321e28dcc7a2bb8709a9bebe12d)
License type: Commerciale, build 2022-09-12
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 530 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 980M (NVidia) Memory: 4GB, Driver date: 6-21-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.48
> Integrated accelerated graphics device with 1 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2020
Driver Version: 27.21.14.5148
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\pm\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6950.16446\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6950.16446
C:\Users\pm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\grasshoppercmd\6.0.0+0\GrasshopperCMD.rhp “GrasshopperCMD” 6.0.0.0
C:\Users\pm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PetersTools\3.1.3\PetersTools.rhp “PetersTools” 3.1.7989.39042
C:\Program Files\SimLab\Plugins\SimLab Rhino 6 Integration\SimLabComposerIntegration.rhp “SimLab Composer Integration”
C:\Users\pm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\lcRhino\2.5.799-pre\lcRhino.rhp “lcRhino” 2.5.799.0
C:\Program Files\Geometry Gym\Rhino7\BullAnt.rhp “bullant” 1.5.6.0

Rhino plugins that ship with Rhino
C:\Users\pm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.22.22255.5001
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.22.22255.5001
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.22.22255.5001
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.22.22255.5001
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.22.22255.5001
C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.22.22255.5001
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.22.22255.5001
C:\Users\pm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

A quick thing we can check as well is to move the contents of your grasshopper plugins folder/components to a temp folder (desktop for instance) and restart Rhino- Grasshopper

%AppData%\Grasshopper\Libraries
%AppData%\Grasshopper\UserObjects

Hi Wim, Hi Japhy,
thanks for your help!!
it’s doesn’t work… i’ve got a new message from grasshopper breakpoint.
Best regards

Try removing the Stripper plugin via the packageManager.

It’s working good!! many thanks!!
now i have this massage when i load a snippet w
massage after load anippet from Brick Box plugin
it Brick Box plug in…

Seems like you have something bigger going on, lets see if anyone else can chime in with a probable root cause.

1 Like

The GH file you were trying to load might contain invalid IDs. Does the breakpoint thing happen in specific GH files?

Hi Pm!

Was wondering if you were able to see any solutions to this by any chance? I am running through the same problem w Brickbox right now.