Grasshopper automatically adjusting tolerances?

Hello. I recently started using Rhino 7 Beta (before Rhino 7 was released of course; I shall upgrade soon). I have this cluster that appears multiple times in my definition, and back when I developed it in R6, it gave me consistent results for all the cases I threw at it (and by that I mean it should output exactly 48 elements).

However when I moved to R7, it would occasionally throw weird results for no rhyme or reason. Here are some of the outputs for the exact same input:

I did not change anything. The only thing I did was to disable and re-enable the cluster to refresh the components.

I can get by for now because my project is coming to a close and I simply refresh my clusters until they give me the right output every time I load the file, but I’d like some emotional closure. Am I doing something wrong? Is Rhino upset with me? How can I make amends?

Just kidding. The real question:

Does GH in R7 dynamically adjust tolerances? and if so, is there way to turn it off to prioritise consistency over performance?

Here’s the cluster: unreliable output (135.9 KB)

Thanks in advance!