Priority: GhpyLoader Error on WIP 7

Hello all,

I have downloaded and installed WIP 7 and I get an error when loading grasshoper. It loads fine in v6 but it can’t seem to find python. Ironpython is enable din the plugins but when i go to run a script it does not know the command.

The error I get is below:

Priority: GhpyLoader
Method not found: ‘Microsoft.Scripting.Hosting.ScriptRuntimeSetup IronPython.Hosting.Python.CreateRuntimeSetup(System.Collections.Generic.IDictionary`2<System.String,System.Object>)’.

Moved to Serengeti > Grasshopper

Hi Emmanuel -

It’s unclear to me what you are reporting here. Is this opening a specific Grasshopper definition?
Have you tried repairing the Rhino installation?
If so, and that didn’t change anything, could you post a Grasshopper definition that causes this error?

Hello Wim. It was happening directly when opening grasshopper. I would get an error when loading, however i was not opening a script. I then I checked rhino and it had the similar error when trying to run a python script. I re-installed multiple versions of WIP and also re-installed multiple versions of Ironpython. I am not an expert at python and I believe it is integrated in rhino now, but I need a standalone version anyway so I tried that too. Non of this changed the error from occuring in WIP. Again Rhino 6 worked fine however.

Attached were the error examples I had, however this ticket can be closed. Somehow when waking up to answer this question, the error has not reproduced itself. This is strange as I changed nothing since testing multiple times yesterday prior to sending a support request to Mcneel. So all is well but the mystery remains.GH_Load_Ex.txt (228 Bytes)

Hello Again,

So I am still having very strange occurrences with errors. One minute I get the same python load error and then next I don’t at startup. Additionally while loading rhino inside, I get an error there as well. I think they are linked all based on python not being recognized. I updated again today and same thing. Without opening files I get occurrences where python is not registered and an error in both rhino and grasshopper. (1.2 MB) GH_Load_Ex.txt (228 Bytes)

Here is an additional snapshot with a wierd workflow. I tried to load rhino inside revit and it took 3 tries before revit could “connect.” I now have it connected and it took two tries for python to be recognized and once recognized I attempted a seminar. I opened a file with nodes associated with rhino inside and grasshopper does not recognize them.

Hi Emmanuel -
this looks like quite a mess and I am not sure who’s in a position to offer advice here.
@piac, do you know what’s going on here or who might have ideas?

Hi, @wim, hi @emmanuel1

I’d say this is an Independent IronPython Installation issue of some kind, different but similar to this one:

For starter, try uninstalling IronPython from the Control Panel. Can Rhino start properly?



Giulio Piacentino
for Robert McNeel & Associates

Hello Everyone…Here is an update:

  1. Rhino 6 works flawlessly during this time with no python errors.
  2. I removed all versions of stand alone python form the computer.
  3. I discovered (I’m very new to Rhino Inside) that you have to open Rhino from inside Revit to actually initiate it. This has been working fine upon this realization, however I did not solve the issue and error that I was having, but Ehsan Iran-Nejad is aware of it and I shared this thread with him.
  4. I have since attempted to open Rhino WIP & Grasshopper and still have errors. I have troubleshooted a bit and I found that if I go to /Tools/Python Script/Run or Edit Python Script prior to running grasshopper the GhpyLoader issue does not happen. If I run grasshopper prior to this I get the GhpyLoader issue and then I can even run a script from rhino directly. I does not recognize the command.

Its a strange issue that is not affecting my work but seems to be a bug.

1 Like

Hello everyone,

I also report the same issue.
When I open Grasshopper in Rhino 7, I get the IronPython loading error message. I also have Rhino 6 and I don’t have the issue.
If I open Grasshopper in Rhino.Inside.Revit, the error message is gone, and using GhPython component works just fine.

I followed @emmanuel1’s process, opening Rhino Python Editor first before opening Grasshopper, and the issue is gone. I have to repeat this process every time I use GhPython component. My colleague gets the same issue.

I also have the same problem and have noted the same thing, where running “EditPythonScript” before loading Grasshopper seems to be the workaround. Also, note that I am having this problem in Rhino 7 release, not in the WIP

@dgoff96 Would you mind opening this grasshopper definition in your Rhino 7 and send a legible screenshot? Please also check if there is a C:\IronBug directory on your machine (5.5 KB)

@eirannejad yup, that was the problem. ironbug is gone and it’s all good now!

1 Like

Great! Glad this is resolved :smiley: