Rhino WIP-Grasshopper plug-in: Ladybug/Honeybee Error on opening .gh file

grasshopper

#1

Just downloaded Rhino WIP and tried a couple of plug-ins I use on a daily basis. After opening the .gh file, the plug-ins throw up a red balloon with the following error message (generated by Ladybug/Honeybee Plug-in):

  1. Solution exception:Method not found: ‘Void Microsoft.Scripting.Utils.ExceptionUtils.RemoveData(System.Exception, System.Object)’.

Cannot load "os" module in python in Rhino WIP
#2

Hi Demian,

Ladybug+Honeybee plugin is built against Rhino 5, Windows version. The development of components for the version 6 will start once Rhino leaves the WIP phase.

Try this workaround.

If it it does not work, post a comment in the same topic, by providing more information (which specific component raises the following error. Which specific Rhino WIP version you are using etc.).

Also for any further Ladybug+Honeybee issues or questions, post them at its Grasshopper3d section.


(Giulio Piacentino) #3

This is an error in IronPython conflicting with Rhino. Uninstall the independent install of IronPython and this will likely go away. Please let me know! @Demian_VonderKuhlen


Patch Command, Site terrain flat surface "blobing"
(Steve Baer) #4

This isn’t quite true. V6 is built to load as many components from V5 as possible. Only components with some native C++ code should be problematic


#5

Hi Steve,

The whole Ladybug+Honeybee plugin is consisted entirely of .ghuser objects. There is only a one compiled .gha file. We already had some issues with people running certain Ladybug+Honeybee .ghuser files on WIP versions of both Windows and Mac.

I do not know if this is related with WIP version specifically, or some part of it. Like using ironpython 2.7.5 instead of 2.7. Or using last Rhino 5 Grasshopper 0.9.0076 instead of WIP 1.0.0004. Or the newest ghpython component. Or using some Windows native classes. As you and Giulio explained recently, some of them can be related with a separate installation of ironpython. I do not know if all of them are caused by this.

The confusion may have been caused by my clumsy use of the term: “against”.
I should have used “for” instead. So it is guaranteed that all .ghuser files will be working for Rhino 5 Windows. There are no guarantees they will be working on WIP version (either Windows or Mac). At least not until Rhino 6 Windows is released.


(Steve Baer) #6

The only problem that we are currently aware of with respect to Ladybug+Honeybee (basically anything python in Rhino) is when users have installed a separate installation of IronPython on their computer. There is a conflict between this installation and the IronPython that ships with Rhino. Uninstalling IronPython has been the fix so far. We plan on updating the version of IronPython that ships with Rhino and hopefully that will make this issue go away.


#7

@piac, getting rid of the extra IronPython install did the trick, works great now. Fist bump for coming up with a fix in such a short amount of time from such a small amount of information.

Thanks again.


#8

Yes, I’ve seen your comment and it worked here as well. Glad that it did!

Some Ladybug+Honeybee .ghuser files also run .bat files, which do not work in Mac WIP version.


(Giulio Piacentino) #9

Well, it’s just not the first time… also, Steve found out about this originally I think. I was just faster at typing :slight_smile:


(Steve Baer) #10

I don’t think we’ll ever be able to fix that issue on the Rhino side :slight_smile:


#11

Yes, that’s why I said that we do not know if all the issues are specifically related with WIP version.
Making all of .ghuser files to run on both Rhino 5 and WIP Windows and Mac WIP would put a tremendous pressure on the development team, as there are total of 335 .ghuser files, with new ones coming. That’s why the official focus is being held only on Rhino 5 Windows.


(Giulio Piacentino) #12

@djordje thanks for all the work you guys do. I think that Steve is just saying that if you encounter any issue with RhinoWIP, we want to fix it for you without remorse :slight_smile:


#13

Glad to hear that Giulio!
We appreciate what you guys did so far.


#14

Just for the future reference.

  1. As @stevebaer mentioned this issue is an issue with importing python libraries and doesn’t have anything to do with Ladybug or Honeybee. You can try to import os library to recreate the error.

  1. What @djordje said is correct for the current Ladybug + Honeybee plugins, however, we are in the process of re-writing the libraries for several reasons including cross platform support. Here is a presentation on how it’s happening with Honeybee for daylight simulation.