Ghost Lines in Rhino 6

Hi all,

I’m having trouble with “ghost lines” appearing on my rhino 6. I have the latest update hoping it would disappear but no. Just like in the image. This lines don’t actually exist, they appear out of nowhere and even disapear with other lines on the model! Can anyone help me with that???
Ghost Lines
Here are my specs:
Intel® Core™ i7-3520M CPU @ 2.90GHz
Intel® HD Graphics 4000 (1GB)

Hello - do these lines always converge on the same 3d location or?
Can you please run SystemInfo in Rhino and copy/paste the results here?


Hi Pascal,
Thanks for replying.

It seems it’s a bug between lines and surfaces (the lines always appear to be connecting those 2 elements, but not necessarily converging from anyone. The more lines and surfaces/solids on the screen, the bigger the mess. These ghost lines change depending on the camera movement, and they appear in shaded, ghosted and wireframe mode… basically any mode with lines activated.

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Educational, build 2021-02-03
License details: Cloud Zoo. In use by: Caio Cintra ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-TN364C7

Computer platform: LAPTOP - Plugged in [98% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel® HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 1-21-2020 (M-D-Y). OpenGL Ver: 4.0.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build
Driver Date: 1-21-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please try updating the video driver to the latest avaiable from the Intel website, and see if that sorts it out? If not, can you also try disabling ‘GPU Tessellation’ in Options > View > OpenGL page.


not resolved, the problem still persists…

So, newest driver and GPU Tessallation off, correct? In that case I’d turn GPU Tessellation back on, and can you also run SystemInfo again with the new driver, and copy/paste the results?


Hi Pascal,

I solved, kind of. Just copied some os the elements for a new file then lines dissapear.
I supose the problem comes up when I try to open and save the same file in different rhinos on different computers and different times… which was my ocasion…

Thak you for yor time.

Hello - do you still have the ugly file? If so can you post it or send to to my attention, with a link back to this topic in your comments?