GH: Surface Domain Length Grid not working

I have been using the paneling tools Grasshopper components for a while, but recently noticed the Surface Domain Length component is always red and I don’t know why.

It always says “1. Solution exception:Object reference not set to an instance of an object.”

I just updated Rhino (6.14) and reinstalled the latest paneling tools (2018.12.17.0). Still the same?

What’s going on? (3.3 KB)

Oh, just realised the example creates a LOT of points. It’s working after a restart, then Rhino telling me I have 2 paneling tools (but identical version). A few crashes later and removing one of them it seems like its working again. Weird.

I spoke too soon. Next time opening Rhino 6 I get the same error:

If I go to Options > Plugins though there is only 1 version. Going to the details and showing the Rhino 6 plugin folder there is only 1 version:

Interesting. So you have 2 problems
1- there seem to be 2 copeis of PT installed. I see the one plugin installed under ProgramFiles>CommonFiles>McNeel>Rhinoceros/6.9>Plugin-ins

You must have installed PT with the option “Anyone who uses this computer”.

Any chance you installed it again using the option “Just me”? If you did, then another PT would be installed here: %appdata%\mcneel\Rhinoceros\6.0\Plug-ins

Can you check that location and see if you have PanelingTools installed there? Let me know, you might need to clean the registry reference as well before installing again. Installing for “Just me” is usually the preferred option unless you run on a network.

2- You have a gh file that is generating dense points.
The definition was probably initially created in different units. Using 0.1 as grid spacing with a very big surface can run you out of memory. To protect in this case (and be able to open your file), disable the GH solver first:

When I initially opened your file, it crashes, so I disabled the solver, disabled the ptDomainLength component, enabled the solver, and measured the length of your curve, it was big:

When use “100” instead of “0.1” for the length, I get the following grid:

I hope this clarifies this issue.

Hi Rajaa.

Oh, that might be possible that I chose a different option the second time installing it (the first time is a few years ago). So weird that Rhino still just shows 1 plugin and not both. I will remove the second one.

Yes, regarding the example I didn’t test it, since the component was always red and forgot its Length in U and V direction and not parameter. So yeah, 0.1 mm is a pretty small size for a grid cell. Surprisingly when it was working again fine, Paneling Tools itself calculated all the grid points, but Rhino couldn’t display the points (it showed a warning about array size and a memory size exceeded warning, but didnt crash for once).

Paneling Tools happily calculated 137,000,000 points in around 30 seconds :slight_smile: So pretty solid code when it works :wink:

1 Like