GH Python 3 Script window out of screen

I know this was already discussed somewhere in the forum, but I was not able to track back the discussion using the search, so I’m creating a new thread

I’m working on a “bigger than average” GH definition and trying to add a Python3 script to the canvas, but when I double click on it, the scripting window that contains the code gets opened out of my screen (working on a 1920x1080 laptop, I have never had additional screens connected in my life, and my resolution has always been set to 100%)

if I add a new Python3 script component, the script windows opens on the right, far out of my screen, and I can’t reach it no matter what I try

the only way out I have found is to create a new empty GH file, place there a single Python3 script, double click on it to confirm the window opens in a visible location (it always does on an empty definition) and copy/paste that component on the original problematic definition: this new Python3script will have its own window opening in a visible place on my screen

BUT :slight_smile:

whenever I save the file and reopen it, the script-window will again open out of the screen again :frowning:

@eirannejad I have recorded a one minute sample of the above

https://www.youtube.com/watch?v=0WgPd_jDDDs [video is not indexed]

I’m running (8.7.24101.10001, 2024-04-10) but honestly I’ve not been using Python3 Script for several weeks, so I’m not able to say if this was already happening like 3 weeks ago in the previous release candidate…

any trick you might have to get that window back on my screen is more than welcome :slight_smile: even workarounds are very welcome :+1:

@inno 8.7 RC is officially out. We have a good amount of fixes related to this. The new behaviour should be that script editor always opens very close (usually to the left) of its component

Would you mind testing that for me?

1 Like

I uninstalled and reinstalled just to stay on the safe side, I think I already had the latest Release Candidate installed :slight_smile: this is a screenshot I took just now

this is before uninstalling:

indeed I get the very same :frowning: I’m sorry :frowning:

on a side note, I assumed it was my file, but I am able to recreate the problem on a blank GH file by just adding Python3 components one after each other and check where their window open :smiley: … the script window keep shifting to the right until it goes out of screen:

system info:

Summary

Rhino 8 SR7 2024-4-10 (Rhino 8, 8.7.24101.10001, Git hash:master @ 2b50f55c58918e10b4e2d13323128fce6021b72c)
License type: Commerciale, build 2024-04-10
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 (NVidia) Memory: 8GB, Driver date: 3-12-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.86
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2080 (NVidia) Memory: 8GB, Driver date: 3-12-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.86
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-12-2024
Driver Version: 31.0.15.5186
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24101.10001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Users\innoi\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Oooof this is nasty. Thankfully I can replicate this here! I’ll put a fix for this in 8.7 very quick. I noticed this is happening with components that are being places futher right on the canvas. There is a logic issue in getting the ‘bounding box’ of where the component is on the screen.

RH-81508 Grasshopper script editor out of screen

1 Like

Ok. Fixed and will be available in next 8.7 build

2 Likes

1 Like

PS

Windows UI/UX:
SHIFT + CTRL + Right click on a task bar program:
2024-04-13 22_25_39-
(italian “Sposta” is “Move”)
After you select that option, you can either:

  • click-and-drag your lost window inside your screen
    or
  • use keyboard arrows to move your lost windows

This problem happened to me too while using Rhino 8 last week, I’ve solved it this way.


Rhino 7 script editor doesn’t pop in the task bar, luckily this problem never occurred to me. If it did, I would panic! :sweat_smile:

1 Like

RH-81508 is fixed in Rhino 8 Service Release 7 Release Candidate

1 Like