Python Edit window issue

By clicking the GH Python node on my home computerthe (2560x1440 res monitor) the Python-Edit window is not accessible. Se the attached screensot! I have created this nod on my company computer (4K monitor):

Are you opening this GH file on the same computer you created it?

Is it possible that you created it with a second monitor plugged in and now opening in a single monitor configuration?

I created this GH file and the Python node on my company conputer.
It has 2 monitors (4K both).

The issue occures when I try to open the GH and the Python node on my home computer, which has also 2 monitors.
The resolution of the monitors is less (2560x1440 both).

I had this before. I fixed it by adding a new python component to the canvas and after opening that one and closing, I could open the other normally.
It happened when I closed Grasshopper while the python editor was open.

Thank you for the advice!

I have tried what you have recommended, but no success:

New Python component
Open it and write a programline
Save the Python program

Open the problematic Python node.
The result is the same.

The python component which has this issue was copied.
In the definition there is another Python node, which is working normally.

GH%20Python-edit%20window%20issue_3

Maybe you can duplicate the problematic one and see if this resolves it?
Otherwise I have no clue

Try opening it in the work computer. Then move the window close to the component. Save. Try and open it at home. I think @ivelin.peychev is onto something. Seems like a display bug when going from one res screen to another

Thanks for the idea Gijs!

After the copy the issue is still exist.

Thanks Michael, I will try as soon I can.
I can try this process earlier end of the next week.

Enxending the GH window for both monitors is not helpnig.

!

The Python edit window is running, but unfortunatelly I don’t know how to access it. (Windows Alt+Tab)

Do you want to try uploading the file and see if someone else can open it properly?

Here is the Python node with the issue:

GH%20Python-edit%20window%20issue_7 Python_node.gh (2.0 KB)

For me it works. I have a ultra wide single screen (34" 4k curved) and it opened right on the edge enough for me to grab it. I saved it below re-positioned closer to the component. See if it opens ok for you.


Python_node-reset.gh (1.7 KB)

I have the problem on my home computer ( 2 x 32" PHILIPS 2560x1440 res).
Maybe the problem coused by definig the python code on a 4k monitor, and try to open on a smaller resolution monitor.
Thanks for you help!

Yes, now it is working on my smaller resolution monitor !

Many thanks.

1 Like

I have experienced this with many applications. The reason is that the position of the window is stored. The best solution is to just disable the 2nd monitor option. Not just to unplug the monitor, but go to windows settings and change it to a single monitor setup. That will move the window and reset its saved position.

Another good practice is to keep the floating window close to the upper-left corner of the second monitor. Since the pixel origin (x=0,y=0) is there and it will for sure have the coordinates in a monitor with lower resolution :wink:

And use the rest of the screen for post-it notes? :memo: :smiley:

1 Like

I’ve Had the same problem. A work around I have used is right clicking on the component and select ‘Show “code” input parameter’. Then I extract that parameter and copy and paste into a new component.

1 Like

Tough :smiley: