Generating surface from points with wonky result

Hello, I am trying to generate a surface from a lot of points but the result is pretty weird. Anyone an idea how to solve this?

Related thread:

Using is not cool with me so I won’t touch your file.

But the code you chose to use (from @Seghier_Khaled) will work only if the grid of points is square with the World XY plane. How many points in this case?

The solution I posted in your other thread uses the square root of the number of points, which only works if the grid of points is square.

1 Like

Is there another way to share bigger files. Already compressed it into a zip folder and it was still too big.

The grid is square again but the number of points is now 4.080.400. I also tried yours but it gave me the same result.

Four million points! 2020 by 2020 points. Yeah, that’s big. How big is the zip file? Do you have a Google account with Google Drive?

Other possible explanations:

  • In your previous file, your points are a long way from the origin. How about this file? Sometimes it helps to move all the points near the origin.

  • The CSet component that @seghierkhaled (@Seghier_Khaled ?) is using can be affected by rounding errors. You might try adding an expression to the pDecon ‘X’ output: round(x,5)

1 Like

So, just tried with moving to origin, but it didn’t change the result. The zip file is 28,6 MB, so just 8,6 MB bigger than allowed.

Your link to “Google Drive: Sign-in” doesn’t work for me.

It should work something like this:

1 Like

Thanks for pointing out :).


I downloaded the file anyway but Rhino/GH has frozen trying to open it. It finally succeeded, looking… working with such larger geometry is a major pain!!

1 Like

Thanks a lot. I know that its incredible frustrating and I thought of dividing into smaller section and stitch them together later but Im afraid they won’t fit. :grimacing:

From what I can tell so far, the sequence of points might be corrupt? I’ll try to sort them but everything takes so very long with this huge GH file and I have other things to do today. Not fun at all!!

1 Like

I have to give up on this, sorry. I have some ideas I’d like to try but this GH file brings my laptop to its knees (it freezes up) and causes it to overheat. Good luck. Four million points that are 1 to 6 million units from the origin is apparently too much for me.

1 Like

Thanks though, very much. I think I was able to fix the sequence and moved it to the origin now. Maybe you can help me with the message that i got, which now sates: 1. The UCount value is not valid for this amount of points. Maybe its a more common error you have some ideas for I could try.

The wire connected to SrfGrid ‘P’ is dashed which means that branches were introduced somewhere. I can’t see where but that is wrong. In this case, there should be only one list of points with no branches, so the wire will not be dashed.

Flattening might work but without seeing how the branches were created, that’s not always best.

Using yesterday’s more manageable grid of points (only 136900 points), this is what I was trying to do: (1.1 MB)

In this case, the sorted points look like this:

I tried flattening before, after I read a conversation in this forum which solved the questioniers problem, but in my case wasn’t helping.
“Flattening might work but without seeing how the branches were created, that’s not always best.” So hearing this was really reassuring. The branch is being created by a plugin, with which I was able to load the points into grasshopper, since they are .shapefile (which further explains the distance from the origin).

Will try this, thanks :+1:

It works! Developing and testing the code with the smaller grid of points was key. I was then able to carefully copy/paste to use the new, larger grid of points without freezing Rhino/GH.

P.S. Here’s what the sorted points look like now:

Once again, GIGO applies - Garbage In, Garbage Out.

By the way, you need to understand data trees!

1 Like

Thanks so much. Sadly I can’t download the file, however, is there any way to spend you at least a coffee for the work you did?

Found a way around it and was able to download.

Ich spreche kein Deutsch. I didn’t share the file correctly at first, maybe that was the problem,

Glad it finally worked. Why are the points out of sequence?