Surface from Points trouble

Hi all I’m trying to make a terrain/surface from a bunch of pointsterrain definition from (21.2 KB) .

However I can’t seem to get it to work for some reason and I’m a bit stuck. I’m basically a beginner in grasshopper so I would appreciate any help I could get.

I’m trying to follow this tutorial but for some reason for me it doesn’t work at the end How to transform Contours into a Rhino Surface - YouTube

You need to internalize your geometry.

1 Like

Sorry I’m not sure I understand…

here is the rhino file if that helps. terrain map.3dm (1.7 MB)

Yeah, of course it helps. What about the ‘Countour’ param? And the error on the SrfGrid is:

  1. A point in the grid is null. Fitting operation aborted

P.S. I found the “Countours” layer but still get the same error from SrfGrid. It looks like what you are trying to do is create a surface from the contour curves?

If you adjust the surface size slightly smaller than theDelaunay Meshoutput, then you won’t get the null points from Mesh/Ray.

terrain definition from (485.7 KB)


Thank you so much, I really appreciate it.

Indeed. The problem is the mesh doesn’t cover the top right corner of the surface in ‘Top View’:


Hi everyone,
I am trying to create a surface basically using the same method. I initially used a regular shape for the bounding box on which I built the surface, but as pointed out at the beginning of this post I received the error null “1. A point in the grid is null. Fitting operation aborted”. So I tried to use an irregular shape so that the mesh could perfectly cover the surface but with no luck. Does anyone has an idea of where the issues is?

Try rebuilding input curves. probably you have kinks in your input curves. I used divide length component here for the same.

I have the same issue as the OP of this thread.
I tried every solution suggested on here, to no avail.

Does anyone have any idea why this isn’t working for me?

here are the files: FLON_Topo initiale.3dm (9.5 MB) Terrain From (11.9 KB)

I really hope someone on here can help me out, I’m kinda lost.


R7 .3dm file cannot be opened in R6.

And this is a DUPLICATE POST where R7 is mentioned there, but not in this thread:

I apologize. I’ll take down the other thread, I figured this one would be more active. I indeed am working on Rhino 7.

here’s the R6 file, in case someone still wants to help me: FLON_Topo initiale_R6.3dm (9.5 MB)


1 Like
1 Like

It appears to work without error in R6? Perhaps your trouble is that your points (surface and mesh) are very far away from the origin?

thank you very much for your reply!

@Joseph_Oster I see why you don’t like duplicate posts now, I apologize again. Do you still want me to take down the other one now that it has a reply? If yes I’ll do so.

@corellaman for some weird reason, when I open the .gh file you gave me in R7, I end up with this:

I didn’t change anything… very weird.
I think my university still has computers with Rhino6 installed, I’ll search for one tomorrow to check if it is Rhino7 messing around with me.

Thanks again!

@corellaman Upon further inspection, I noticed that the panel in the top right (the one linked to the “create Set” Node) shows 2 lines in my case (0 True; 1 False) in my case, whereas in your image there’s just one line (0 True). Maybe that’s an indication that R6 and R7 don’t quite work in the same way? Just guessing…

1 Like

Does this work for you in R7? The white group moves the surface and contours to the origin before using your unmodified code in the purple group.

Terrain From (15.0 KB)


I told you: Murphy’s Law :stuck_out_tongue:

Anyway, as Joseph points out, distance-to-origin issue, whatever that means…
The work-around I had previously shared dealt with that to ‘bypass’ said issue.

Joseph’s contribution will leave you with less to deal with by fooling Rhino into thinking stuff is closer to 0,0,0. Grab that instead if you’re trying to stick to the ‘tutorial example’.

Regarding the R6 vs R7 issue, I copy-pasted all into R6 and saw no problems:

here’s a gh 6 file:
contour (529.8 KB)

@Joseph_Oster Thank you very much, that solved the issue!!

Note to myself: never do something far away from the origin.

thanks @corellaman as well for your precious help.