"GenerateResource" task failed unexpectedly

Hi discourse,

I’m having a simple problem but I can’t seem to get around it. I’m trying to build one of my projects on another computer, and I’m pretty sure I’ve set up all of my Visual Studio settings to match what I had on my other computer but I keep getting the error: “the ‘GenerateResource’ task failed unexpectedly…”

I tried following the tutorial for creating my first plugin in visual studio on windows, and I easily got that project to work by following directions however, I can’t seem to build this project that I’ve copied over from another computer. I’ve changed the path that looks for the external application to run, and I’ve located the rhinocommon.dll on this computer.

When I run the plugin I copied over, Rhino opens, and I can type in my plugin name, and it will launch, however, any changes I make to the code aren’t affecting the .rhp. I then tried deleting my .rhp, and building the plugin, and no new .rhp gets generated.

Any help would be greatly appreciated. Thank you.


Try Googling “GenerateResource’ task failed unexpectedly” - you will find lots of information…

I figured out my issue, I had copied over all my files from the project and brought all the “junk” with it. So the solution was to just ‘copy’ it over using github, which is the way you’re supposed to do it, and it worked. Thanks for your quick reply.