Error : Create new C++ Plug-in project in Visual Studio 2017


(Takehirosakurai) #1

Hi
I have tried to create some plugins in visual studio 2017 and I downloaded vs2017 and rhino SDK while following tutorials(http://developer.rhino3d.com/guides/cpp/installing-tools-windows/).
However, I got an error showing below when create a new project in VS2017.

Unable to read the project file “test.vcxproj”.
C:\users\t\Desktop\test\test.vcxproj(49,5): The imported project
"C:\users\t\Desktop\test\PropertySheets\Rhino.Cpp.PlugIn.props" was not found. Confirm that the path in the declaration is correct, and that the file exists on disk.

I confirmed that .props file is not in test folder. test folder what automatically created has only test.vcxproj file.
How should I deal with it ??

My environment: Win 10, Rhinoceros 6


Takehiro


(Dale Fugier) #2

Hi @takehirosakurai,

There is a bug in the Rhino 6 SR1 SDK installer in that it creates the wrong registry key. Try this:

1.) Uninstall the Rhino 6 SR1 SDK

2.) Install this version, which is Rhino 6 SR0.

https://www.rhino3d.com/download/Rhino-SDK/6.0/release

The name of downloaded msi should be rh60sdk_6.0.18016.23451.msi.

Does this help?

– Dale


Create new C++ Plug-in project in Visual Studio 2017
(Takehirosakurai) #3

Thanks, Dale

It works. but a new error occurred in testing.
I followed the tutorial on below page.


It works up to “Boilerplate Build”.
When it started debugging, there are 70 errors related to opennurbs(attached pic).

There is no name of plug-in in rhino options.
How should I do with it?
Takehiro


(Dale Fugier) #4

Hi @tak,

Set your Error List to only view Build Only messages.

intellisense

– Dale


(Takehirosakurai) #5

Dear Dale,
Thank you for your quick reply.
However, there is still a problem.
I followed tutorials and progressed showing below.

  1. Open testPlugIn.cpp and modify some lines and delete #error line.
  2. Start debugging
  3. rhino 6 automatically run

In above step 3, I can not find new plug-in named test in Tools>Options>Plug-ins in rhino 6.
Are there some omissions above procedure?

Takehiro


#6

Did you try to load it?

In plugins manager browse .rhp file load it and then run it via command line


(Takehirosakurai) #7

Dear Petras,
It worked! Thank you!
it was just the rudiment.
Tak