Fuzzy haze around objects

As I’m rendering some files, I’m noticing a fuzzy haze around the entire object if the object has depth on it. I’m trying to figure out how to get rid of this haze or if it might just be because the computer I’m using is low spec (like, it shouldn’t be used for rendering, but I don’t have access to my normal computer atm).

I’ve turned shadows off to ensure that it isn’t some odd shadow effect. There was no chance, haze is still there.

In the below image, I’ve drawn a box > created surface > ExtrudedSrf > select the outline > 3mm. The colors are basic and changing them or the type doesn’t change anything.

Any help is appreciated.

In Blender i would tell you to increase the number of rendering cycles.
You can switch to final quality in the render settings. That will reduce the image noise.

But this will take a fair amount time

Tried DPI adjustment, but it made some seems look like they weren’t meeting properly.

Does look like I was on the lowest quality in the list (50). Bumped it up to Good Quality (500) and seems to have drastically reduced the haze/noise. Just need them to look nice, so I’ll go with this :D.

Much appreciated!