Frequent Rhino 6 Crashes using Grasshopper

I have been experiencing a number of crashes lately since installing the release version of Rhino 6. These crashes seem to occur when I’m working in Grasshopper and adjusting something about preview - such as enabling/disabling preview for a group of components. If I debug I get:

Unhandled exception at 0x00007FFBF675CAA7 (vcruntime140.dll) in Rhino.exe: 0xC000041D: An unhandled exception was encountered during a user callback. occurred

I’ve submitted crash reports each time. Unfortunately I haven’t nailed down a behavior that consistently reproduces the issue - but I will update if I figure out anything more specific about when these are occurring. It’s frequent enough to be a real nuisance - Rhino has crashed 3 times in the last 3 hours. Thank god for GH autosave!

1 Like

Hey Andrew,
This sounds like the most frequent crash we’ve been seeing get reported. I just got a (hopefully) fix for this inat the end of this week. Please give the next SR3 release candidate a shot which should be available on Tuesday. If you want to see if the crash is fixed before then, maybe @brian can get you a daily build.


I have experienced same problems with SR2
Just installed SR3, but the “Eval” component in a GH definition that was fine yesterday does not work any more

This seems to be the same problem as mentioned here. I have no idea what could possibly cause this, the GH expression parser is fully implemented within the GH plugin itself, but a reinstall seems to have fixed it for @mcmucher.

Oh hang on, try “Sin” with an upper case.

1 Like

Hi David
Yes I get exactly the same problems (with the same errors launching GH), sorry I haven’t seen this discussion
btw the upper case doen’t change anything
Still trying to get it work !

Ok thanks for testing. We recently did make changes to all string comparisons that weren’t culture independent, and I thought maybe we released a build that switched to case-sensitive function testing.

The way GH collects all available functions is potentially dangerous. If a recent update tightened certain security measures, it might explain why certain people are suddenly running into this.

Can you run this file and show me what data is in the panel? (47.2 KB)

Mine looks like this:

yeah crashed for me too … I was only moving some nodes around at the time in GH and one crash happened when I opened windows 10 picture viewer to look at a picture …

I am also experiencing many daily crashes.
I have submitted many reports but I had no reply so far.

In my case the crashes happen when I switch or save clusters. It feels like there is a bottleneck of data flow. Maybe related to graphics…

Thanks Roberto,

the crashes all end up in our database and similar ones are automatically combined. Eventually someone has to try and figure out who is best suited to deal with a specific crash family. This all takes time, and even then fixing it is not always straightforward. Basically, almost all the easy crash bugs have already been fixed since we started collecting crash dumps, and now all we’ve got left is weird ones.

Submitting these reports is always good though. If nothing else it allows us to keep an eye on which problems are common and need fixing the most.

I am no complaining at all, I appreciate all the hard work put into it.

One more small piece of info for you guys.
While I was testing it my files using both the WIP and Beta versions, everything worked flawlessly.
Not sure if this will help you narrow it down in any way…

We made a change to some of the Rhino framework that supports Grasshopper in this build:

Our testing has shown more stability when adjusting and changing things in Grasshopper. Can you give it a try?

1 Like

I am also experiencing crash when launching grasshopper. It seems to happen at 22 % when loading GH Python if that helps at all. See screen shot. And thanks for all the hard work.

This manifests with a crash report window? If yes, please always send the reports.

Recently we have had a lot of crashes from the V-Ray plugin trying to load. It’s entirely possible the crash happened when GH was beginning to load the next plugin after python, and there wasn’t time to update the progress bar to reflect this. Do you have any vray associated GHA files on your machine? If yes, try and change their file extension to *.notgha and see if that fixes it.

I found one gha component in Chaos Group program files and renamed it using .notgha. Unfortunately, it did not fix the issue. I ended up uninstalling Vray in total and that fixed the issue.

Has anyone else with VRay running in Rhino 5 had this issue?

I will try reinstalling with out the Grasshopper components.

Thanks David.

Yes, it’s a very common problem these days. Lot of crash reports coming in originating in Vray. We don’t really have a solution to this other than to tell people to uninstall.

1 Like

Yes, I found the same problem in Rhino 6. The problem is the Grasshopper Vray components from Rhino 5 Grasshopper.

I simply went to the special components folder and deleted the Vray plugin for Grasshopper. The component should be here:


Does that help?

4 posts were split to a new topic: Crash with compiled GHPY component

i’m having the same problem, I have deleted all the vray files I can find but it has not worked,

this is the crash report

System::AppDomain::CurrentDomain->UnhandledException event occurred

SENDER: Name:DefaultDomain
There are no context policies.

EXCEPTION: System.DllNotFoundException
MESSAGE: Unable to load DLL ‘VRaySDKLibrary’: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
at VRay.RendererUtils.releaseVRayRenderer(IntPtr renderer)
at VRay.VRayRenderer.Finalize()

If you have a recent Rhino6 Service Release, you should have access to the _GrasshopperLoadOneByOne command (it may or may not auto-complete). This will specifically ask you per GHA whether it should be loaded. When you click ‘yes’, the exact path to the GHA file will be put in the clipboard, so if it crashes during that plugin, you can go and find the actual file.