Rhino 6 - Grasshopper Eval


#1

Recently Updated to Rhino 6.I was originally working in a Rhino 5 grasshopper.

I have a bunch of points. I use dynamic pipeline to select points and then deconstruct - reconstruct XYZ to get coordinates. I then use an expression to reformat the coordinates into more useable data.

Format("{0:0.000000}, {1:0.000000}, {2:0.000000}", x.x, x.y, x.z)

It worked fine in Rhino 5, but now the eval doesnt work and says “1. Expression generated an error for (x): Unknown variable encountered: Format”

If i remove “Format from the Eval expression, it says 1. Expression generated an error for (x): Invalid expression. (1364)”

EDIT: If I click on the expression function list, it’s empty.


Frequent Rhino 6 Crashes using Grasshopper
GhPython error messages at launch
Rhino SR3 : GhPthon last exception boundary
(David Rutten) #2

Any hope of a file that reproduces the problem?


#3

Hi David,

I’d be happy to create a generic file. It’s just a random scattering of points in rhino. My problem may be that my expression function list is empty or the expression formats have changed.

Also FULL DISCLOSURE: I copied my r5 library into my r6 library. I didn’t notice these errors before but theyre popping up when i start grasshopper fresh. 2nd EDIT: I deleted my %appdata% grasshopper folder and still got the errors.

@DavidRutten Attached samples that wont work for me. evalgh.gh (7.9 KB)
evalr.3dm (29.1 KB)


(David Rutten) #4

No the expression language hasn’t changed. The only change (years ago now) is that for expressions inside parameters the nickname is no longer used to represent the variable, it’s now always x. But if you’re using an Expression component then that doesn’t matter.

I cannot replicate your problem, so I really need a file that shows exactly what doesn’t work on your machine.


#5

Hi David, I uploaded a grasshopper file that doesn’t work on my machine. Is there something else you have in mind?


(David Rutten) #6

You’re using a non-standard object (Dynamic Pipeline) to import the points. I don’t have that one, but if I replace it with the regular pipeline object everything still works fine. Would be nice to know what sort of data is really inside that parameter. I noticed the file you uploaded is different than the screenshot.


#7

Hi david,

They’re different because I tried to replicate the process you used in the screen shot hoping that would work. Doesn’t work if even if dynamic pipeline isn’t used and i just select the points manually.

EDIT: So i uninstalled - and tried to wipe everything Rhino from my computer -then reinstalled. The expression function list is working now so everything should be good. I’m used to transferring toolbars/plugins/ect from old R5 installs to new, but the transition to R6 has been less seamless for me than i hoped.


#8

@DavidRutten

Ok, definitely still having problems.

I had to uninstall and reinstall a few times to notice what was happening.

I installed using “rhino_en-us_6.2.18065.11031.exe”. App data is clean so i don’t have any toolbars or scripts or plugins. If I open grasshopper I don’t get any issues or errors, and eval works as intended. The expression library is full.

If i close, and reopen a few times, everything is ok.

However, rhino tells me to update. I download the update and install to 6.3.18064.23201, 03/05/2018

When i open grasshopper, i get these errors and eval no longer works. Expression library is empty.


(David Rutten) #10

I’ll have to defer to the python and installer guys as to why this might be happening.


(Giulio Piacentino) #11

Hi @mcmucher

I have 3 questions :slight_smile:

  • is something else printed in the Rhino Command line when the error occurs?
  • if you run the _GrasshopperDeveloperSettings in V6, what do you see? (can you post a screeshot?)
  • do you have any *.ghpy files on your computer (especially maybe installed with plug-ins)?

Thanks,

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#13

Thank you for helping, @DavidRutten


#14

Hi @piac,

I think part of the problem was being on the release candidate version. I was having trouble with the auto update - so might have accidentally changed it. I’m not having the problems on version 6.2.18065.11031. I don’t know about the development process, but hopefully these issues don’t carry forward with the next release.

I’ll need to reinstall the update to test those issues. I was getting issues after uninstalling Rhino, clearing the %appdata% and program data folders, reinstalling, running (no issues), applying 6.3 update, issues. The expression function list in Eval is populated pre-update, empty post update.

I don’t think something in the command line was there, because it was constant even after i would try different things and close and reopen the program many times. I searched for *gphy but couldn’t fine anything on my computer.

EDIT:

I get the error same messages loading grasshopper up as i posted above. That’s with a clean appdata. If i keep normal appdata folder in there, i get more loading errors.

  1. Command line is empty. Last command is “Grasshopper”

image

3)Can’t find any *gphy files (looked in C:\Program Files\Rhino 6\Plug-ins) Looked in grasshopper components and here’s what’s in there


(Giulio Piacentino) #15

The thing is, they are “.ghpy”, you should search for: *.ghpy (the spelling differs!)

You will likely experience them if we don’t resolve them now :slight_smile: I am trying to add a few more tests so that we know better where the problem is located. Thanks for the hints on this part!


#16

buh…sorry for the spelling error.

I tried again with *.ghpy. Found ghpython2.gha in grasshopper libaries and theres a ghpython2lib folder in Plugins/IronPython. In both 6.2 and 6.3, i could see ghpython being loaded in during grasshopper loading screen.

EDIT: That being said - I’ve uninstalled 6.3 and gone back to 6.2 so i can work. Would it help checking for*.ghpy again after installing the 6.3 update?


(Giulio Piacentino) #17

As we speak, I am adding some additional checks to SR3 that I hope will help pinpoint the issue. This should hopefully get this part of the problem sorted.

Bugtracker issue RH-44705 contains the report for this.