Freeze when opening old script after update


Even when opening a GH file while solver is turned off I still get the popup below. I can not click it away and need to taskmanager terminate Revit.

GH was made in February. I have updated WIP and plugin since. It worked last time.

This leads to a more general question - how does scripts update as the plugin updates and components that are used changes?

Does this happen to more people when opening the file?
RhinoInside Revit geometry strip .gh (6.6 MB)

"Some of the changes mentioned in sections below, might break your existing Grasshopper definitions. We hope this should not be causing a lot of trouble and rework for you, since in most cases the older components can easily be replaced by new ones without changes to the actual workflow. "

Best to not count on it (scripts updating) while they are still in Beta.

The script doesn’t freeze on my computer.

Latest WIP + Revit 2019

ok. Thanks for the quick replies.

Using the GH bifocals plugin I can see what RiR components were where even when I open the file outside Revit, take a screendump and recreate it with new components inside Revit. Good enough!