Finding Annotation with Missing Font

Hi,

I’m using Rhino 7. I get this dialog when I load the file:
MissingFont

I see in the command line there are four instances. Is there a way I can find them all without clicking all my text?

Also, when I do find one I change the Font from Merriweather to say Arial and save the 3dm file. When I reopen it I get the same warning - the change didn’t take. So I think I’m “fixing” it in the wrong spot.

Any help appreciated!

Thanks,
Mark

can you post your file ? and what is the precise error description in the command line ?
did you try to copy paste the entire geometry into a new document ?
… some ideas:
is the font used in a Block-Definition (wich might not be placed in the Document ?)
is the font used in a Dimension Style ?
a hidden object ?

Hi,

Here’s the error description:
Read 4 annotation objects that reference 1 font that is not installed on this device.
Missing font:
Merriweather (Regular)

So this is no mystery other than where to find the text! I can go and select each piece one by one and look. What I was hoping for was if something like SelBadObjects to help me find them. That doesn’t do it though.

I did find one instance of it. In the Properties dialog, I can change the font in the Font: drop-down to Arial. But when I select it again it changes back to the missing Merriweather.

I’ve attached a trivial Rhino file with one text object which has the missing font. When I change it to Arial it changes back the next time I select it. It must be needing to be changed elsewhere, I just don’t know where.

Mark
test.3dm (29.0 KB)

Dear Mark Meier - i get the same error-message, when i open your document on mac os x 10.15.6 with Rhino Version 7 (7.2.21012.11002, 2021-01-12)
But i can change the font, save, reopening the text is still “Arial”. Sorry but my Rhino 7 licence is currently on the Mac - can t check PC. - on the Mac Side behaviour is as expected.
Did you check if the behaviour is the same for other missing / uninstalled fonts ?
Maybe some general Font Problem on the machine / system ?
If you have the latest version on the latest system it s maybe a bug - then report it to @pascal
sorry if i can not help further. -tom

Hi Mark - this may help - it cannot find specifically missing font items but it will find text that has starting characters that ‘should’ be in the font you name in the box… if you enter the font family that you see in the message box, it should find them - it does not look at the primary current font family being used, assuming you are looking for text where that is ‘wrong’

guaranteed partly tested.

selMissingFontName.py (926 Bytes)

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"

@meier - can you make a file that has an annotation style using Merriweather in the dimensions as well as text? I can probably find those as well if I have an example.

-Pascal

1 Like

Thank you, Pascal. This worked nicely and I fixed all my files. I appreciate your help.

Mark