Filleting problems


#1

I’ve having a few problems filleting around joins between pipes. I’m using the rolling ball type and quite often the result ends up with naked edges. What should I do in such circumstances? I’ve changed the radius but it hasn’t helped. Is it just that some things can never be filleted?


#2

Are you trying to fillet offset surfaces there? Thing in that case is, unless the original tubular shape was perfectly smooth at the seam then the offset won’t be, there will be a small discontinuity at the seam you can see there represented by the thick isocruve, messing up the fillet. If it’s close, in situations like that you can just take the fillet surface you get, split it at the seam point, and see if the ends don’t in fact Join up okay or just leave a small gap you can fill in, it’s not like on what you’re doing anyone’s going to notice if that fillet isn’t perfectly smooth at that point.


#3

Thanks, but I’m not sure what that is. What I have in the picture are two tubes. They fit perfectly as they were created by piercing one with the other and then trimming. I ran the Check command and also Show Naked Edges before proceeding with the trim. After the trim, naked edges appeared as can be seen in the picture I posted.

I used exactly the same techniques in other parts of my model. Sometimes Trim works, sometimes not.


#4

Sorry, being stupid. Yes, I know what an offset surface is.

To answer your question, yes and no. I am using offset surfaces but I am not filleting the offset one. The offset surface is inside the original. I am only trying to fillet the original, not the offset one.

The ones you see in the picture are the originals and the offset ones are inside. The whole object is joined and checked. No naked edges anywhere until after the fillet.


#5

Fillet Edge command is very prone to failure.The Filletsrf command is a lot more robust… Filletsrf will work in many situations where filletedge fails. Post examples if you need help.


#6

Thanks but FilletSrf fares no better for the example in the picture I posted.

A few times I tried Fillet Edge, the result threw an error saying that improper geometry had been generated and that I should report an error. Opting to do so simply loaded a help page of things I could try to avoid the problem.


#7

Have you tried filletsrf with the untrimmed pipes? Tick the trim option in the command. This is only an alternative, may not be a solution.


FilletSrf bug
(Chuck Welsh) #8

If you attach the 3dm file we can probably fix the bug, Many examples that look like this do work, and there are many reasons why one might fail. Without the model, there’s not much we can do. If you don’t want to post the model to a public forum, you can send it directly to me, chuck@mcneel.com.

Thanks,
Chuck Welsh
Robert McNeel and Associates


#9

you can try:
1.
- Explode polysurface to srf
- Use RebuildEdges command to repair Edges
- Join srf and FilletEdge

  1. Use Srfseam command to move seam to another point (RebuildEdges command if need) -> FilletEdge

  2. Change Absolute Tolerance to bigger (examples standard tolerance is: 0.001, you adjust to 0.01), then FilletEdge. Remeber adjust 0.001 after FilletEdge.

  3. I usually use this way when FIletEdge failure, because above way need more time to try:
    - DupBorder ->Curve
    - Rebuild curve (if need)
    - Pipe form Curve -> Surface
    - Use new Pipe Surface to Trim two Srf…
    - BlendSrf
    - Certainly OK, but wrong radius :slight_smile:

(Sorry all, my english is bad)


#10

That’s very kind of you Chuck. Thank you. Please see attached.

I’ve exploded the model and put the problematic pipes into different layers so that you can see which ones I’m having problems with. I managed to fillet the other ones.

I’m looking to use a fillet of around 2mm. I tried rolling ball and adding extra handles with varying fillet sizes with no luck.

Blood vessels 4-10-fillet problems.3dm(5.2 MB)


#11

Thanks. I’ll look into your suggestions.


(Chuck Welsh) #12

Thanks for sending the file. I see a few problems that we need to fix. I’ll make bug reports for those and will look at them in the near future. Also, I think maybe your tolerance of 0.1 is a little too loose for a model with surfaces as narrow as you are attempting to make. You might try 0.001. Unfortunately, it is best to set the tolerance at the beginning of the modeling process, rather than change it part way through. Finally,the attached file, which is 3 of your surfaces, demonstrates a case that FilletEdge currently does not handle. If you join the 3 surfaces together and attempt to fillet the edge between the red and the grey, with radius 2, the new fillet would run into the old one and will not trim properly(currently this fillet fails completely and that is one of the bugs I am reporting). The usual workaround of using FilletSrf will not work here because the old fillet has radius 1,5 and a radius 2 ball will not roll over it. Also, the fillet between red and grey has a problem at the seam of the red surface because that surface is not smooth. This problem may go away if the red surface is created using a the tighter tolerance of 0.001. I hope this is of some help.

Chuck Welsh
Robert McNeel and Associates


#13

The main problem you have that makes filleting difficult is that the surfaces have poor continuity at the seams. When you fillet surfaces that are tangent then the ends of fillets will line up nicely. If surfaces aren’t tangent then the fillets don’t match up where they cross the discontinuity. For small discontinuities you can use match surface to get the fillet ends to match up. But it is better to make surfaces with good continuity to avoid problems.

The tolerance in your file is pretty loose for the size of the objects. A tolerance of .01 mm should work pretty well for this model.

Enclosed is a file with the fillets made using FilletSrf. I didn’t do the whole thing just a few of the fillets you were having problems with. The cyan fillets show how to deal with areas where the 2mm fillet runs into the existing. 1.5mm fillet. For those fillets you need to use the extend option in filletsrf. After untrimming this gives you the complete fillet as if the 1.5 wasn’t there. You then add the small 1.5 mm segment on top of the 2mm and trim out the part of the existing 1.5 mm fillet. In general you should plan to make your bigger fillets before making smaller ones so that the smaller can overlap the larger. .

BloodVesselsX.3dm(433.3 KB)


#14

Jim and Chuck, thank you so much for taking your time to help me.

I’m annoyed at myself re. the tolerance. I’d set it to a lower number when experimenting and forgot to reset it.

I’m glad that at least I managed to help unearth a bug or two.


#15

With Blood_vessels_4-10-fillet_problems.3dm, i use SrfSeam to move seam to other point, then FilletEdge OK with radius 2mm.


#16

Thank you very much PatentRiko for trying that for me.