Fillet on a more complicated brep not working


I am wondering what gives with this part. I am trying to fillet everything but the extreme edges of this brep without any luck.

I have been able to fillet just the edges of one protruding element, but all of them doesn´t work even with very small radii. I also tried to fillet all of the edges, with the same error messages.

All the tutorials I have seen deal with geometries such as a cube, I´ve seen nothing more complicated.

Help very much appreciated, I dislike turning stuff into meshes for smoothing.

Thanks! (7.6 MB)

Fillet Edge ‘E’ (Edges) expects a list of integer index values (0 to numEdges-1), not points.
‘R’ (Radius) is also required.

There can be problems when radius and edge separations conflict.

Which edges do you really want to fillet, and at what radius (or list of radii)?

After failing for awhile, I baked your original brep and realized that the embossed shapes go to zero height near the edges, which could easily cause Fillet Edge to fail?

I’ll post the code I was playing with in case it helps but, to keep the file size small, without your brep internalized. You can copy/paste that from your original file. (30.3 KB)

Thanks Joseph

The edges I´d like to fillet are everything but the ones listed on the unconnected panel.

I used the point on curve to extract the edge numbers as proposed on one tutorial of Parametric House.

I see the design is complicated for the fillet to work, and now it looks like it is impossible in the end, due to the infinite amount of angles.

Thanks for the effort anyway


OH! I totally missed that. Looks like you have one stray edge in that list, 4147. Filleting only the outermost edges is simple, especially when you have a list of index values. (7.6 MB)