Fillet Edge on Solid deleting partial model

Hello, I’ve been trying to fillet an edge on a fairly simple shape. I’ve tried various methods but keep running into issues. The closest I’ve come to getting what I want is solid>fillet edge>face edge, but still having issues. I’ve tried adjusting the various points individually but always end up making the problem worse and distorting the model further.


No matter what I keep ending up with an incomplete model.

I’m a carpenter/fabricator, having fillet edges on designs is an important detail when showing clients but a problem I seem spend a lot of time on Rhino trying to get right.

Any tips on streamlining the process would be greatly appreciated!

Thank you,

Hi Brian - please post a file with the object, I’ll take a look.

-Pascal

This does happen regularly to me too (with blend edge) not too often but not too rare either.
Extracting the surfaces and trimming them with the border curves and joining all pieces together does fix the problem quite easily.
Still, this can be quite annoying.
Edit: this is Rhino 7 on windows.

Hi Pascal,

Thanks for the quick response. Here you go…
test1.3dm (4.3 MB)

Thank you,

Absolute tolerance is currently 0.01.
Change the absolute tolerance to 0.001 and FilletEdge works properly for me.
Options > Units > Absolute tolerance

An absolute tolerance 1/10 the fillet radius will usually but not always be sufficiently small, but as this example demonstrates the absolute tolerance should be smaller.

https://wiki.mcneel.com/rhino/faqtolerances

Note that the absolute tolerance should be set sufficiently small at the beginning of the model. Changing the absolute tolerance while modeling does not change any existing geometry; it only affects operations after the change.

1 Like

The 3 dotted joints in the image below are more than 1° G1 discontinuous. To maintain a solid with _FilletEdge, do one of these:

  1. Make sure that the edges relevant to the 3 sharps are not included in the _FilletEdge. (Window-selecting the solid will include them.)
  2. _Match the 3 joints to Tangency continuity before _ExtrudeCrv to a solid. _FilletEdge the remaining sharp edges.

image

My standard tolerance is 0.001mm and I rarely use radii?blends smaller than 0.5.
Still this problem with disappearing surfaces happens regularly to me.
As I said it is fairly easy, albeit annoying to fix.

Hi Norbert - if possible, please post, or send me, an example when this happens again.

-Pascal

I will try to remember when it occurs the next time, but keep in mind that these files usually are under NDA.
If I can reduce them to a small part that keeps behaving badly I will send a file.

Hi Norbert- of course - thanks.

-Pascal

Hi David,

This worked great for what I’m working on. Thank you very much for the quick and easy fix!

please mark David Cockey s answer as solution, so others don t need to dig into this topic an see that it s already solved and no further help is required. thanks

( ・∀・ )ゞ