Fillet curves issue - extrusion precision


I have a problem with extruding curves which have been filleted.

I noticed that when I extrude a curve, the precision of the polysurface created at the rounded corners decreases if the curves are made of more segment (see attached pictures).
The problem persists not only during the visualization, but also during the rendering phase.

I am not sure which is the reason behind this behaviour, and I would like to understand why (it might be that the answer is something very basic, and sorry for it in that case).
I tried very different possibilities, as well as modifying the tolerance precision of the file but it led to no conclusion.

Thank you very much for any advice you could give me.

I suspect this will explain what you’re seeing:

Thank you very much @John_Brock.
It was helpful and it clarified me some concepts I am definitely not that strong at.

However, as a further point, is it somehow possible to control the mesh count of a polysurface, making it more or less “smooth” according to the design need?

I will keep on checking the forum and other online discussions to make my mind clear, so again sorry for disturbing and thank you already for your time.

The Mesh command and other tools that create meshes intended for export have both a “simple” slider control, and a “detailed” control where you can set the mesh creation parameters for the mesh as needed.
For example, when exporting a mesh for STL printing, setting the density of the mesh so the facets do not show in the print for your specific printer are exactly why the detailed controls are exposed.

John’s comments are relative to mesh objects and exporting as meshes. The “render mesh” which is used by Rhino for display of NURBS surfaces and SubD in shaded mode, render mode, etc is distinct. The render mesh settins are in Options > Document Properties > Mesh.