Fillet/blend edge question

Because you can not run a filet / blend edge only in red border? (The fillet is extended beyond the curved edge).

Because the extension of the fitting does not run with a path of type blend? (Green curve).

In rhino 6 should improve this kind of situation. Thanks.

Hi Davide -My guess is the surface is not G2 right there, is that correct?


I send you the file.
I used an edge blend and does not seem to work, as I would like.
fillet_blend edge question.3dm (219.9 KB)

Why the blend edge is not running a G2 connector also the extreme?

Hi Davide - how are you setting the handles? Here, if I splitEdge at the ends where the radius drops to zero, it looks like what I think you want… Handles added at the edge between the vertical surfaces. and end handles set to zero.


I wish the fillet / blend edge is running as in the figure (as opposed to being straight, should be curved)

and if the connection stretching over, that would be correct in the sides to follow the green curve (with continuity of G1 or G2 on both sides)

OK, thanks, I see what you are after - got it now - I’ll see what we can do.


Thanks Pascal.
Why the fillet / blend edge extends incorrectly (yellow curve)?
I think it would be more correct that he had a path equal to the green curve, G1 or G2.

Wait… are you asking for a hard end to the fillet, or a smoother/better taper if just that one edge is selected?


Give the possibility to perform the fitting or as above (where there is written OK), or extend the fitting, beyond the curved edge, but following the green curve.

I hope I explained. I am Italian…

Hi Davide - It seems to me that if you want the latter, you can force it in the way that I described - otherwise there would need to be more UI to set where the end will be. My thought is that the hard end (Your ‘OK’) should be the correct behavior if possible and to make it extend, you can split the edge as I mentioned.


Certainly, currently Rhino v5 implements the filet / blend edge of the red edge, extends it further, but it is extended following the yellow curve, not the green one (more correct).
They are two different possibilities, both valid.

You might think about adding a “Partial fillet” option, if enabled the fillet functions as the left image.

If “partial fillet” is not selected, the file extends beyond the edge (but not as presently, with G0 profile, but G1 or G2).

In the ultimate wip Rhino 6 this fillet edge red (0.4) does not work. Check it out
fillet edge failed.3dm (319.3 KB)

Also check the shell of the circular face (thickness 1), on the one side there is an abnormality

I would take a look at solutions of this type, in which fillet / blend edge can not be generated.
Where there are discontinuities Rhino struggles a lot to do the fillet …
fillet_blend edge failed.3dm (824.9 KB)