File writing plugin failed

I habitually export to pdf in vector but am today experiencing the error box ‘file writing plugin failed’ (image)
if I export in raster the image is chopped (image).
version is up to date.
is there a way to fix the bug?
![Screenshot 2022-12-26 at 17.00.03|690x124](upload://vk
KaRaGoziAn.pdf (1.1 MB)

Hi Jakob -
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim,
I found the problem, with an imported PDF that I was tracing over- something rotten. I trashed the content of this part of the project and am back to normal.
The said ‘bad source’ failed the plugin when off screen.
I do not recall if it was in a distinct layer - If anyone is reading this I suggest you put all imports in their own special layer.


1 Like


Hi Wim

I experience the same problem. usually I export my pdf via the print command to be able to choose the layout page I wanna export. This option is not available through export. But since the latest Mac update going through print takes literally 3 minutes to export 1 A3 layout. because emac tries to beat thumbnails of all the layout pages content.

I therefor tried to go through export / pdf but get the same error message as listed above

File writing plugin failed

and rhino crashes afterwards. I’m running this test on my template file, almost no content in it. thanks

Hi Charlotte -

When you use the ExportAll command, you can pick the layouts to print to PDF:

I’m not seeing any crash reports from your eMail address in the system. Are you sending those in when the crash reporter appears?
At any rate, please run the Rhino SystemInfo command and copy-paste the result here.