Pdf export issues

Hallo,
I’experiencing a wierd issue when exporting layouts to pdf.
everything looks fine in the preview in the print-dialog:

2021-06-25_13h55_29

but the geometry in view gets shifted relativ to geometry in layout on export:

2021-06-25_13h59_11

sorry, I can’t really share the file, nut sure I can recreate it with another one, this is the first time I’ve come across this

Hi Johannes -

I’m not able to reproduce that issue here.
Can you run the Rhino SystemInfo command and copy-paste the result here?
-wim

Yes, sure:

Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05001, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Commercial, build 2021-06-09
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 5-6-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.59
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-6-2021
Driver Version: 27.21.14.6259
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino
C:\Users\PD16\AppData\Roaming\Grasshopper\Libraries\elefront421\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\TeDAsharp (ce983e9d-72de-4a79-8832-7c374e6e26de)\0.1.0.0\TeDaSharp_050.rhp “TeDAsharp” 0.1.0.0
C:\Users\PD16\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\export_PDF.rhp “PDF Export” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

…I cleared out the file quite a bit to be able to share, still has the issue:
pdf_issue.pdf (117.0 KB)
pdf_issue.3dm (220.3 KB)

Thanks for the file and the SystemInfo.
That file behaves as expected here…
There has been a lot of work done on PDF output lately, could you update to the current Rhino 7.8 release candidate and try again?
pdf_issue-wd-print.pdf (1.1 MB)
-wim

updated to release candidate, but it unfortunatly didn’t to the trick for me.
pdf_issue02.pdf (336.3 KB)

saved the file as Rhino 6 file and exportet again from there and it worked
pdf_issue02_R6.pdf (1.1 MB)

while uploading I just noticed that my Rhino 7 pdfs have a much smaller file-size than the the pdf you and rhino 6 generated (1.1 MB vs a couple hundred KB)

Hi -
The file size should be the result of the dpi and paper size. The one that I posted was created on an A3-sized page with 600 dpi. The one I’m attaching here now is on an A3-sized page with 100 dpi.
pdf_issue-wd-export.pdf (62.0 KB)

How are you creating the PDF and which settings are you using?
-wim

I would recommend disabling your 3rd party plugins and restart Rhino to test if they have any effect on the pdf export.

Sorry, yes the file size was related to dpi, had cranked it down to 300…
Issue persists after disabling plugins that do not ship with rhino and restarting.
worked around using Rhino 6 for now

I also can’t repeat this bug. Can you send us your settings file? Maybe there is something in it that causes this issue to happen. The settings file is located at
C:\Users{user name}\AppData\Roaming\McNeel\Rhinoceros\7.0\settings\settings-Scheme__Default.xml

settings-Scheme__Default.xml (42.8 KB)

I am able to repeat this bug with your settings. I haven’t found the exact setting causing the problem, but do see what you are seeing.

There is something in the print command saved settings causing the problem. Here’s a modified version of the settings file you could use that should fix the issue while I work to track down and fix the bug. Close Rhino and copy this file on top of the settings file at
C:\Users{user name}\AppData\Roaming\McNeel\Rhinoceros\7.0\settings\settings-Scheme__Default.xml

settings-Scheme__Default.xml (40.7 KB)

I’d been occupied with other things the last days and finally got to apply your file, it seems to work again as it should, thank you!