FBX - all objects unwelded?

unhandled

#1

Hi,

if I import FBX data, than the objects are unwelded. I tried to enable and disable unwelding. Is it a bug? Or wouldn’t it help to get an option for welding?

ScreenShot9352


(Nathan 'jesterKing' Letwory) #2

Are you sure you didn’t have Flat Shading checked?

fbximport_flatshaded


#3

No, because _weld helps.


(Nathan 'jesterKing' Letwory) #4

Can you share the bottle fbx? I couldn’t reproduce with the sphere model.


#5

Attached one of the files from my client.

fbx.rar (5.1 MB)


(Nathan 'jesterKing' Letwory) #6

It looks like the model isn’t exported properly. When I bring it into blender the bottles are also faceted.

kuva

I suppose an automatic weld on mesh objects could be useful. I imagine that until such an option exists you could create a macro that does the import and weld automatically.