Fade away edge - advanced surfacing

First post here. Stuck on this fade away edge on sunglasses. Curve network keeps producing wobbly edges on the patch. Any tips? Lettme know if you want the file to review.

1 Like

In the surface Curve Network dialog box, try to decrease the Edge tolerance.
try a value of 0.1 first, if it doesn’t work go down to 0.001 or 0.0001.
I’m guessing it’s a tolerance problem, but without seeing the file it might be something else.

Hi Jim - always better to post the curves and surfaces.


I’ll see about the tolerance thing, in the meantime, here is the file if it helps. glasses_r6.3dm (251.6 KB)

a more precise wobble but still a big dent in the surf for some reason…

Hi Jim - I’m not sure why your main surface is split up into pieces - I’d think that makes it all harder… in any case, for what it is worth, I think I’d make this from simpler surfaces, maybe something like the attached file. I moved the seam point at the corner a little to make the surfaces slightly more similar to one another there, I don’t know if that is allowed.
glasses_r6_PG_V5.3dm (102.2 KB)
I untrimmed your surfaces so as to have just one with a hole in it.


I like a lot how you simplified the setup. I had split the surface up like that so I had edges to gather surface continuity. How did you get the blend curve to run curvature continuous to the surface without an edge to align off. I secretly hate having to break up the main surf like that because it breaks up the edge along with it and even if I join the split panels back together the edges stay broken up and its a headache if I need the clean edge back at some point down the road. but its the only way I’ve thought of. Whats the secret? Nice moves.

Hi Jim - just fyi, you can always split edges if you need to (SplitEdge command, also see MergeEdge, MergeAllEdges) without cutting up surfaces.


I am still confused as to how you were able to get a blend crv to run off the main surface with curvature continuity. I have tried to replicate the file you sent and I can 't without at least adding a crv on surface. could you walk me through the steps you did to produce the two new surfaces in the file you sent. are they sweeps, networked, blendsrf? I don’t see it. You can check this latest file where I try and recreate your file. not as clean surface and much higher degree results from a network, did you rebuild the surfs after making them?glasses_r7.3dm (132.4 KB)

Match curve!

final answer glasses_r8.3dm (529.5 KB)

Hi JIm - A line between the two ends and Match > SurfaceEdge (Preserve other end = Position) is how I did it but also BlendCrv > Edges option with Point as the input at one end, the surface edge at the other. That’s nice because you get to adjust the curve.