Extrusions no longer split tangents (4.0)

Hi all,

Since some time ago, Rhino suddenly no longer divides an extrusion at tangent points for no reason.
Let’s say I’ve drawn a rectangle, and I want to extrude it. Usually it creates 4 different surfaces, one for each side. (Not counting any caps). However, when I extrude a rectangle now, it extrudes the whole edge into one single surface as if it’s a circle and I cannot explode it either. I once managed to completely reïnstall Rhino after a lot of work which temporarily solved the problem. But now it seems it’s stuck in there permanently.

Here’s an image of the problem: http://i.imgur.com/44LB1hH.jpg
As you can see, the center isocurve is missing as well which should appear.

Does anyone know how I can solve this problem? It has been really annoying as this messes up any surface that I extrude.

I’ve searched everywhere but I’m unable to find any solution or setting that may help solving this problem.
Does anyone know how to fix this? Reïnstalling doesn’t work. Even after removing everything related to Rhino from the Windows registry, it apparently still remembers my preferences or setup.

Any help is greatly appreciated.

Run the command CreaseSplitting and set it to Yes (it accidentally got set to No). To fix existing objects, select them and run DivideAlongCreases and set SplitAtKinks to Yes.

HTH, --Mitch

try running the command CreaseSplitting then select ‘split along creases’.

edit- hey!

Thanks a lot for the quick replies!
Unfortunately Rhino says it’s an unknown command when I type in CreaseSplitting. Is it a RH5 feature perhaps? I’m using RH4.
This does seem to be the command I’m looking for.


Ah, I found the command as a plugin for RH4: http://www.rhino3d.com/download/Rhino/4/SplitCreases
Installing this plugin enabled the command and solved the problem. Thank you very much guys!

Oh, yeah, I forgot it was not “native” in V4…