DivideAlongCreases SplitAtTangents=Yes

Hello fellow Rhino users!

Is there a way to make Rhino always spilt at tangents?

Best regards

Hei Fredrik -

Have you tried the CreaseSplitting command?

Thank you Wim

I will give it a go and see how it behaves :+1:

Seemed at first to work as expected…
Until I discovered that Rhino still doesn’t always split at tangents when this is enabled, even though DividealongCreases SplitAtTangents=Yes does split them.
This happened jus now when using ExtrudeCrvTapered.

Yeah, Extrude Tapered has lots of problems that McNeel has persistently ignored for decades.
What you have to do is explode your curves before extruding. If you want to keep your joined curves, explode then extrude then copy the result to the clipboard then undo back to before you exploded the curves then paste the result.

1 Like

Actually CreaseSplitting only applies to G0 (position) creases. Normally it should always be left on (Yes).

The ExtrudeCrv command has its own SplitAtTangents option within the command. In V7 ExtrudeCrvTapered does not however. It looks like it has been added to the V8 WIP.

A long time ago I lobbied for a global SplitAtTangents option for all commands (as opposed to individual options in each command), but that did not get any traction with McNeel…


I agree, and lobby for that also. It’s so easy to forget. Personally I would always keep it at Yes.