Fillet Edge V4 and V5


#1

I have never had this problem in Rhino 4. In the file attached, there are three objects. The one on the right is what I have gotten in the past in Rhino 4. The other two are original and the result that Rhino 5 is giving me. Not sure what the problem or difference is. They are not the exact same, but the process I used is the same for both. Any ideas?

Thanks,
Matt

Fillet Edge-Forum.3dm(1.1 MB)


#2

Looks like I put this on her about 2 minutes too early. I noticed that one of the surfaces needed to be split. That has been an issue for me as Rhino 5 tends to make surfaces as one surface rather than a bunch of different surfaces joined as a polysurface. I notice this mostly on extrude curve and sweep commands. Any way to go back to the old way. I have used split at tangents, but it doesn’t seem to break them up as much as I like so I end up using split by isocurve.


(Pascal Golay) #3

Hi Mark- one way out is DivideAlongCreases> SplitAttengents=Yes. However. These objects are not the same- the one from V4 has the vertical end where thw fillets go as a simple trimmed face, and the other one has a loft or something to close the end. The V4 version has the bottom edge left unfilleted, the V5 is filleted

-Pascal.


#4

Dividealongcreases just became my favorite command. I got edge figured out as well.

Thanks Pascal


#5

This should not be the default. There is a Rhino command that sets this behavior, it is called CreaseSplitting. If you have it set to SplitAlongCreases=Yes (default setting), Rhino will make polysurfaces from extruded kinked curves (like a rectangle). If you set it to No, it will make kinked single surfaces. Something I have noticed is that a few random users have gotten their CreaseSplitting set to No for some reason - stray cosmic rays, divine intervention, something else, who knows - so the first thing I would do in your case is check this setting in your V5. DivideAlongCreases is the remedy after the fact, but it’s best to prevent this from happening if you don’t want it - IMHO…

–Mitch


#6

Mitch,

Yes, that setting was set to no. Thank you that is exactly what I was looking for.