Extruding closed curve creates open extrusion instead of closed solid polysurface

Since refreshing my laptop windows and reinstalling Rhino 6, whenever I extrude a closed curve, it makes an open extrusion instead of a closed solid polysurface. Is there a setting I need to change to enable standard closed solid polysurface extrusion?

there is an option inside the command line named "solid = yes/no " perhaps the last time you use that command, was with the solid = no and rhino keep that value.
Another thing is if the input curve is planar or not, if it isn’t planar, the result will be open.


Fixed! Thank you!

1 Like


note that there is a global _UseExtrusions command which affects other commands. More info here.


UseExtrusions does not affect whether a open or closed object is created by the various extrusion commands. It affects the way the object is stored in Rhino.

The solid option controls the caps. But it does not produce a polysurface which is what the OP is trying to get according to the title.


Hi Diego-
I am having the same problem as PeterB. However, I am selecting the option 'solid=yes/no
and am still getting a closed curve after I extrude it. i.e. I have an elliptical planar curve I am
extruding 2 mm and selecting ‘solid.’ When I am extruding it, shows the perpendicular lines
that indicate a solid. But when I hit enter or click the mouse, the solid lines disappear and I
am left with only an extruded curve?

Hello - does it looks this way in shaded vieports?


Hi Pascal-
It looks shaded, like a solid object in the shaded viewports, but without the perpendicular lines in the wireframe.

Hello - that is expected - extrusion are their own kind of object even though they behave like polysurfaces and surfaces for the most part.



1 Like